Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want create a Unity lens, I follow this exemple : http://developer.ubuntu.com/2012/04/how-to-create-a-wikipedia-unity-lens-for-ubuntu/

I use :

quickly create unity-lens wikipedia

When I try :

quickly install 

I have this error :

morgan@morgan-laptop:~/wikipedia$ sudo quickly install
Traceback (most recent call last):
  File "/usr/share/quickly/templates/unity-lens/install.py", line 62, in <module>
    os.mkdir('/usr/share/unity/lenses/%s' % lens_name)
OSError: [Errno 2] No such file or directory: '/usr/share/unity/lenses/wikipedia'
ERREUR: la commande install a échoué
Annulation

So, I create a directory (thanks to : https://bugs.launchpad.net/singlet/+bug/1100114) :

mkdir /usr/share/unity/lenses

And when I try to install again :

quickly install 

I have this error :

Congrats, your new lens has been installed.
compizconfig - Info: Backend     : gsettings
compizconfig - Info: Integration : true
compizconfig - Info: Profile     : unity
WARN  2014-04-22 14:45:00 unity.glib.dbus.server GLibDBusServer.cpp:579 Can't register object 'org.gnome.Shell' yet as we don't have a connection, waiting for it...
ERROR 2014-04-22 14:45:00 unity.debug.interface DebugDBusInterface.cpp:196 Unable to load entry point in libxpathselect: libxpathselect.so.1.4: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou dossier de ce type
ERROR 2014-04-22 14:45:00 unityinit <unknown>:0 unable to create file '/home/morgan/.cache/dconf/user': Permission non accordée.  dconf will not work properly.
ERROR 2014-04-22 14:45:00 unityinit <unknown>:0 unable to create file '/home/morgan/.cache/dconf/user': Permission non accordée.  dconf will not work properly.
ERROR 2014-04-22 14:45:00 unityinit <unknown>:0 unable to create file '/home/morgan/.cache/dconf/user': Permission non accordée.  dconf will not work properly.
ERROR 2014-04-22 14:45:00 unity.launcher.entry.remote.model LauncherEntryRemoteModel.cpp:50 Unable to connect to session bus: Impossible de se connecter : Connexion refusée
CRIT  2014-04-22 14:45:00 unity <unknown>:0 Unable to get org.ayatana.bamf matcher: Impossible de se connecter : Connexion refusée
Trace/breakpoint trap (core dumped)

What is the new way to create a Unity lens ?

share|improve this question
1  
I doesnt look like the errors you get is related to the "lens" you are trying to install. But the instructions you try to follow is made for Ubuntu 12.04, and there seems to be a bit changes made in Ubuntu/Unity regarding lenses and scopes. Haven't found anything about lenses in 14.04, only scopes, so probably you need to use scopes further. –  Joachim Jun 22 at 18:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.