Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ubuntu 13.101 (and maybe upstream gnome) introduced very annoying bug: pressing keyboard layout switch shortcut makes focus go away to some system window, then back to window where shortcut was pressed. Some applications have some actions bound to change of focus, for example twitter (in browser) closes reply text input field when losing focus, etc. So ubuntu's native keyboard switcher isn't suitable for me, until fixed.

X has builtin switching mechanism, and it is much better, in addition to that it does not involve focus switching, it switches immediately (gnome switcher also sometimes lags).

How can I set up xkbmap options so settings will remain after reboot and will not be reset by Gnome?

What I've tried:

First, just executing setxkbmap:

setxkbmap -layout "us,ru"
setxkbmap -option "grp:caps_toggle,grp_led:scroll,compose:ralt"

But it works only:

  1. For current session
  2. Until Gnome will overwrite it (for example touching something in gconf's org.gnome.desktop.input-sources triggers reset).

Second, adding xkb options to Xorg config:

Another option is to add following to xorg config:

Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "us,ru"
        Option "XkbModel" "pc105"
        Option "XkbVariant" "pc105"
        Option "XkbOptions" "grp:rctrl_toggle,grp_led:scroll"
EndSection

Xorg understands that during startup:

[    33.791] (**) Option "xkb_rules" "evdev"
[    33.791] (**) Option "xkb_model" "pc105"
[    33.791] (**) Option "xkb_layout" "us,ru"
[    33.791] (**) Option "xkb_variant" "pc105"
[    33.791] (**) Option "xkb_options" "grp:rctrl_toggle,grp_led:scroll"

But switching configuration still resets later, likely by gnome.

Third, gconf

enter image description here

I have xkb-options and sources set in org.gnome.desktop.input-sources, but Gnome still sets xkb to single English layout:

$ setxkbmap -print -verbose 10
Setting verbose level to 10
locale is C
Trying to load rules file ./rules/evdev...
Trying to load rules file /usr/share/X11/xkb/rules/evdev...
Success.
Applied rules from evdev:
rules:      evdev
model:      pc105
layout:     us
options:    grp_led:scroll
Trying to build keymap using the following components:
keycodes:   evdev+aliases(qwerty)
types:      complete
compat:     complete+ledscroll(group_lock)
symbols:    pc+us+inet(evdev)
geometry:   pc(pc105)
xkb_keymap {
    xkb_keycodes  { include "evdev+aliases(qwerty)" };
    xkb_types     { include "complete"  };
    xkb_compat    { include "complete+ledscroll(group_lock)"    };
    xkb_symbols   { include "pc+us+inet(evdev)" };
    xkb_geometry  { include "pc(pc105)" };
};

Fourth, another option in gconf

enter image description here

Setting org.gnome.settings-daemon.peripherals.keyboard also does not work for me. Nothing changes.

Upd 1: There is discussion recommending to remove /usr/lib/gnome-settings-daemon-3.0/libkeyboard.so. At least this fixes some resets of xkbmap (i.e. after lock screen).

1 I use 14.04, but problem with losing focus is still not fixed. (Unconfirmed report in upstream Gnome)

share|improve this question
    
Have you tried setting the layout correctly in gnome and then adding the two setxkbmap commands to your ~/.profile? That way, they will be run each time you log in and since the same settings are there in Gnome, it should not change anything if it resets. –  terdon Apr 21 at 12:52
    
@terdon it resets even after screen lock. And it resets to "us-only, no switch" state, not to settings defined in org.gnome.desktop.input-sources. –  kolen Apr 21 at 13:29
    
Strange. Are you sure you are using Gnome and not Unity? Have you tried changing the settings through the normal GUI instead of dconf-editor? –  terdon Apr 21 at 13:33
    
@terdon yes, it is unity, but it uses lost of gnome's stuff, like gnome-settings-daemon, which possily resets keymap. –  kolen Apr 22 at 15:34
    
So, have you tried setting the correct settings from the Unity GUI? –  terdon Apr 22 at 23:25

2 Answers 2

I just read this article on screenlocking, which may be related. According to the article, screenlocking has the intended consequence of blocking input devices and manipulating locales. Seems like you have a few options:

  1. Stop locking the screen, probably this includes the greeting screen as well which serves a similar function
  2. Use different power management tools
  3. Stop using ibus for im-switching (Perhaps FCITX?)
  4. Create a hook for screen unlock events as described here.

There is an interesting discussion of this and related events which can be found on the ubuntu-dev mailing list: https://lists.ubuntu.com/archives/ubuntu-devel/2013-November/037768.html

share|improve this answer

First, just executing setxkbmap:

setxkbmap -layout "us,ru" setxkbmap -option "grp:caps_toggle,grp_led:scroll,compose:ralt"

But it works only:

For current session
Until Gnome will overwrite it (for example touching something in gconf's org.gnome.desktop.input-sources triggers reset).

Well as far as Gnome "resetting" it i dunno. I do know how you can get to stay every reboot though as I had to do the exact same type of thing for my Logitech mouse. It has multiple buttons which I wanted remapped a certain way and I had to have that set at restart.

So what you do for that is create a text file. Then in that text file type:

#!/bin/bash

and right below that put in your commands. As example my mouse looks like this:

#!/bin/bash
xinput set-button-map "Logitech USB-PS/2 Optical Mouse" 1 2 3 4 5 8 9 6 7 10 11 12 13 14 15 16

next you would save that as whatever name you want and move it to some place like your home directory. it has to stay there "forever".

then just open up your Startup Applications and Add the file to your startup and then you dont have to worry about it lasting only for the session. it will be ok to reboot your computer because your settings will come back through the file you just added.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.