Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Intel CPU and Nvidia GPU(Ubuntu 12.04).

I do the following things:

1.Download Public key

2.sudo rpm --import Intel-E901-172E-EF96-900F-B8E1-4184-D7BE-0E73-F789-186F.pub

3.rpm --checksig opencl-1.2-base-3.2.1.16712-1.x86_64.rpm

4.rpm --checksig opencl-1.2-devel-3.2.1.16712-1.x86_64.rpm

5.rpm --checksig opencl-1.2-intel-cpu-3.2.1.16712-1.x86_64.rpm

6.rpm --checksig opencl-1.2-devel-3.2.1.16712-1.x86_64.rpm

7.rpm --checksig opencl-1.2-intel-mic-3.2.1.16712-1.x86_64.rpm

The checksig are all correct.

8.Download Intel OpenCL SDK

9.tar xvf intel_sdk_for_ocl_applications_xe_2013_r3_sdk_3.2.1.16712_x64.tgz

10.cd intel_sdk_for_ocl_applications_xe_2013_r3_sdk_3.2.1.16712_x64

11.sudo ./install-cpu.sh

Then I get the following error:

rosfuerte@rosfuerte-K53SM:~/tool/intel_sdk_for_ocl_applications_xe_2013_r3_sdk_3.2.1.16712_x64$ sudo ./install-cpu.sh In case of failure please consult README file
rpm: RPM should not be used directly install RPM packages, use Alien instead!
rpm: However assuming you know what you are doing...
error: Failed dependencies:
    /bin/sh is needed by opencl-1.2-base-1:3.2.1.16712-1.x86_64
    lsb-core-amd64 >= 4.0 is needed by opencl-1.2-base-1:3.2.1.16712-1.x86_64
    libnuma.so.1()(64bit) is needed by opencl-1.2-base-1:3.2.1.16712-1.x86_64
    libstdc++.so.6()(64bit) is needed by opencl-1.2-base-1:3.2.1.16712-1.x86_64
    /usr/sbin/update-alternatives is needed by opencl-1.2-devel-1:3.2.1.16712-1.x86_64
    /bin/sh is needed by opencl-1.2-devel-1:3.2.1.16712-1.x86_64
    /usr/sbin/update-alternatives is needed by opencl-1.2-intel-cpu-1:3.2.1.16712-1.x86_64
    /bin/sh is needed by opencl-1.2-intel-cpu-1:3.2.1.16712-1.x86_64
    ld-linux-x86-64.so.2()(64bit) is needed by opencl-1.2-intel-cpu-1:3.2.1.16712-1.x86_64
    ld-linux-x86-64.so.2(GLIBC_2.3)(64bit) is needed by opencl-1.2-intel-cpu-1:3.2.1.16712-1.x86_64
    lsb-core-amd64 >= 4.0 is needed by opencl-1.2-intel-cpu-1:3.2.1.16712-1.x86_64
    libnuma.so.1()(64bit) is needed by opencl-1.2-intel-cpu-1:3.2.1.16712-1.x86_64
    libstdc++.so.6()(64bit) is needed by opencl-1.2-intel-cpu-1:3.2.1.16712-1.x86_64
    libstdc++.so.6(CXXABI_1.3.1)(64bit) is needed by opencl-1.2-intel-cpu-1:3.2.1.16712-1.x86_64
    libstdc++.so.6(CXXABI_1.3)(64bit) is needed by opencl-1.2-intel-cpu-1:3.2.1.16712-1.x86_64
    libstdc++.so.6(GLIBCXX_3.4)(64bit) is needed by opencl-1.2-intel-cpu-1:3.2.1.16712-1.x86_64
    libstdc++.so.6(GLIBCXX_3.4.9)(64bit) is needed by opencl-1.2-intel-cpu-1:3.2.1.16712-1.x86_64
    /usr/sbin/update-alternatives is needed by opencl-1.2-intel-devel-1:3.2.1.16712-1.x86_64
    /bin/sh is needed by opencl-1.2-intel-devel-1:3.2.1.16712-1.x86_64
    ld-linux-x86-64.so.2()(64bit) is needed by opencl-1.2-intel-devel-1:3.2.1.16712-1.x86_64
    ld-linux-x86-64.so.2(GLIBC_2.3)(64bit) is needed by opencl-1.2-intel-devel-1:3.2.1.16712-1.x86_64
    lsb-core-amd64 >= 4.0 is needed by opencl-1.2-intel-devel-1:3.2.1.16712-1.x86_64
    libfontconfig.so.1()(64bit) is needed by opencl-1.2-intel-devel-1:3.2.1.16712-1.x86_64
    libfreetype.so.6()(64bit) is needed by opencl-1.2-intel-devel-1:3.2.1.16712-1.x86_64
    libglib-2.0.so.0()(64bit) is needed by opencl-1.2-intel-devel-1:3.2.1.16712-1.x86_64
    libgobject-2.0.so.0()(64bit) is needed by opencl-1.2-intel-devel-1:3.2.1.16712-1.x86_64
    libgthread-2.0.so.0()(64bit) is needed by opencl-1.2-intel-devel-1:3.2.1.16712-1.x86_64
    libICE.so.6()(64bit) is needed by opencl-1.2-intel-devel-1:3.2.1.16712-1.x86_64
    libnuma.so.1()(64bit) is needed by opencl-1.2-intel-devel-1:3.2.1.16712-1.x86_64
    libpng12.so.0()(64bit) is needed by opencl-1.2-intel-devel-1:3.2.1.16712-1.x86_64
    libpng12.so.0(PNG12_0)(64bit) is needed by opencl-1.2-intel-devel-1:3.2.1.16712-1.x86_64
    libSM.so.6()(64bit) is needed by opencl-1.2-intel-devel-1:3.2.1.16712-1.x86_64
    libstdc++.so.6()(64bit) is needed by opencl-1.2-intel-devel-1:3.2.1.16712-1.x86_64
    libstdc++.so.6(CXXABI_1.3.1)(64bit) is needed by opencl-1.2-intel-devel-1:3.2.1.16712-1.x86_64
    libstdc++.so.6(CXXABI_1.3)(64bit) is needed by opencl-1.2-intel-devel-1:3.2.1.16712-1.x86_64
    libstdc++.so.6(GLIBCXX_3.4)(64bit) is needed by opencl-1.2-intel-devel-1:3.2.1.16712-1.x86_64
    libstdc++.so.6(GLIBCXX_3.4.9)(64bit) is needed by opencl-1.2-intel-devel-1:3.2.1.16712-1.x86_64
    libX11.so.6()(64bit) is needed by opencl-1.2-intel-devel-1:3.2.1.16712-1.x86_64
    libXext.so.6()(64bit) is needed by opencl-1.2-intel-devel-1:3.2.1.16712-1.x86_64
    libXrender.so.1()(64bit) is needed by opencl-1.2-intel-devel-1:3.2.1.16712-1.x86_64

However, I have some libraries in my filesystem already. For example, when I use locate, I can find libX11.so.6 in /usr/lib/x86_64-linux-gnu/. Do I miss something?

Thanks!

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.