Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I need Ubuntu 11.04 drivers for a Matrox G400.

I put the video card in and nothing came up on the screen, so I guess there are no drivers of any kind for Ubuntu 11.04.

So do I have to load the drivers first using my old card, if so, how do I do it?

share|improve this question

closed as too localized by jrg Feb 24 '12 at 22:40

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
This question appears to be abandoned, if you are experiencing a similar issue please ask a new question with details pertaining to your problem. If you feel this question is not abandoned, please flag the question explaining that. :) –  jrg Feb 24 '12 at 22:40

3 Answers 3

Does it recognize your new card

lspci | grep VGA

Have you run

sudo apt-get update; sudo apt-get upgrade

Then checked in Additional Drivers?

share|improve this answer
    
I ran sudo apt-get install xserver-xorg-video-mga and it said it was already the latest version. so were do I put it so the matrx g400 will reconise it, as it is now when I put the g400 card in nothing come up on the screen except the boot amd bios page then it goes blank. –  jbander May 26 '11 at 0:34
    
Its not in additional drivers –  jbander May 26 '11 at 0:35
    
once booted can you get to TTY1 with ctrl+alt+F1 and try the commands there? –  Cas May 26 '11 at 2:01

Checked in Matrox's website for drivers and as assumed they have left out the legacy drivers.

You can do two things

  • Try using one of g450 series, see if it resolves the issue.
  • or mail the authority asking, that you need an old driver.
share|improve this answer
    
What do you mean? There are legacy binary drivers on that site. –  Cas May 26 '11 at 2:00
    
There isn't Matrox g440 driver. G-Series starts with G450. –  iamcreasy May 26 '11 at 2:18
    
G-series starts at G400 however a G440 graphics card does not actually exist. If you read the main text it specifies G400. There is a link on that site called Legacy (Older) Drivers. –  Cas May 26 '11 at 2:26
    
@cas Matrox G440 exists. But its kinda weird that they have, G100, G200, G400 even a G450(legacy!). But no G440. –  iamcreasy May 26 '11 at 2:28
1  
I have never heard or seen of a G440 and I have used many Matrox cards over the years. –  Cas May 26 '11 at 2:37

Matrox G400 should have working open source drivers supplied with x.org. It may be that the correct driver just doesn't get loaded automatically. This happens with some older intel graphics chips too.

Try putting this into /etc/X11/xorg.conf

Section "Device"
    Identifier "Configured Video Device"
    Driver "mga"
EndSection

Section "Monitor"
    Identifier "Configured Monitor"
EndSection

Section "Screen"
    Identifier "Default Screen"
    Monitor "Configured Monitor"
    Device "Configured Video Device"
EndSection
share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.