Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Environment: Lenovo T530 running Windows 7. Have installed Ubuntu 14.04 on a virtual machine using VM Virtual Box. Have installed all the updates from both Virtual Box and Ubuntu.

Problem: While in Ubuntu's desktop and other Ubuntu initiated programs, the window is reduced to about 3x4 inches showing in the middle of the rest of my regular Virtual Box window. I am seeing only the upper right hand of the screen output of what I would normally see. Please help.

I've seen How do I install Guest Additions in a VirtualBox VM?

But, none of these answers works in 14.04.

share|improve this question
5  
I don't think this is a duplicate. When installing the Guest Additions with Ubuntu 14.04 I get "Warning: unknown version of the X Window System installed. Not installing" –  mjaggard Apr 22 '14 at 15:31
3  
This is definitely not a duplicate question (even if the answer is the same). I found this only via searching about screen res problems, and learned here that "guest additions" is the answer. (If I already knew to ask about "guest additions", I wouldn't have had a question/problem.) –  Greg Hendershott Jun 22 '14 at 0:56
2  
The answers aren't even the same. Generally you would use the guest additions iso that can be mounted from the host, but it seems to be specific for 14.04 that you must install via the apt repo for it to work properly. –  flungo Jul 26 '14 at 9:22
2  
2  
I've been having problems with this as well. Guest additions appears to have installed correctly but full screen mode still has a small os display. kraxor, where are you seeing system settings? –  user322522 Sep 1 '14 at 5:33

7 Answers 7

You basically need the Guest additions, log into the Virtual Machine to install the following packages:

sudo apt-get install virtualbox-guest-dkms \
virtualbox-guest-utils virtualbox-guest-x11

Finally restart the VM to complete the installation.

share|improve this answer
1  
Thanks, I misunderstood this step before I read your answer and thought I was supposed to install Guest Additions on the host machine. d'oh. –  melancholynaturegirl Dec 29 '14 at 18:08
1  
@symphonyblade: Those packages are meant to be installed on the Guest OS indeed. –  Sylvain Pineau Dec 29 '14 at 18:50
1  
Yup, got it working thanks to you :) –  melancholynaturegirl Jan 2 at 20:01
    
Does this work for ubuntu 12 also? –  carter Jan 26 at 17:57
15  
Doesn't work on my Ubuntu 14.04 LTS installation. I get The following packages have unmet dependencies: virtualbox-guest-x11: Depends: xorg-video-abi-15 Depends: xserver-xorg-core (>= 2:1.14.99.902) –  THelper Mar 4 at 12:09

I had the same problem as you. I did these steps, maybe helps you too:

  1. Go to System settings → Software and Updates → Additional drivers
  2. Use x86 virtualization solutions...
  3. After that reboot your VirtualBox

My VirtualBox is working perfectly.

share|improve this answer
    
Thank you kraxor. –  Rustam Aug 1 '14 at 19:17
    
Oh my gosh. After trying so many other things and wasting so much time, this easy solution did the trick. –  Adrian Carr Jan 26 at 22:51
    
Simple as 1,2,3 - works. –  acme Feb 20 at 16:55
    
Verified on Ubuntu Mate 14.04.1 –  Elder Geek Feb 28 at 21:38
3  
Setting this option seems to go ok on my Ubuntu 14.04 LTS installation, (no error messages) but after the reboot I still have 640x480 resolution and no option to change it. –  THelper Mar 4 at 12:20

On virtualbox you have to install "Guest Additions". There is no need to set a resolution via Ubuntu settings. From your guest window select

Devices -> Insert Guest Additions CD image

In Ubuntu open a terminal, navigate to cd folder (usually /media/VBOXADDITIONS*) and run

sh ./VBoxLinuxAdditions.run

Note that you should have a working compiler gcc/g++

share|improve this answer
3  
This fails with an error saying it looks like guest additions had been installed from a different installer or package. The only solution is the answer saying to use apt-get to install the three packages. –  Jistanidiot Jun 25 '14 at 20:00
2  
Exactly the same here trying to install Xubuntu 14.04 64bit on VirtualBox. Installing Guest Additions from mounted CD image is not working - it breaks X Server installation. Instaling with apt-get from public repositories as advised by Sylvain works. –  ZeKoU Jul 31 '14 at 11:36
2  
+1 This is the only solution that worked for me. As a preliminary step, it was very important to update the VirtualBox Manager to the latest version available. I have posted here a new answer with some additional details. –  Antonio Mar 10 at 17:26

After having first tried installing the Guest additions, which didn't work, I found another solution elsewhere: linuxbsdos.com.

Use Xdiagnose from the Dashboard. Search for and launch Xdiagnose, then enable all the options under the Debug section. Click the Apply button, then close the window and restart the system.

That's what finally did the trick! Now I get 1024 x 768 resolution instead of 640 x 480.

I never uninstalled the Guest additions, so it might be I needed to take both these measures.

enter image description here

---------- EDIT ---------

I have come to realize that the solution described above is just a fallback, in case installing the Guest Additions failed for some reason. I have finally managed to successfully install them, and can now choose from a bigger range of resolutions in the display settings. Here is how I did it, after having tried all of the above.

One thing I had already tried earlier was


sudo apt-get install virtualbox-guest-dkms virtualbox-guest-utils virtualbox-guest-x11
This is not enough in itself, but might be a necessary prerequisite for the following steps (of which some might not be necessary...).

  1. Update Virtualbox to the latest version (currently 4.3.24)
  2. In Terminal in the Guest system type:

    sudo apt-get install dkms
    sudo apt-get install build-essential module-assistant
    sudo m-a prepare

If you have no top menu in the Guest system, it's because you're in scale mode which causes it to be hidden. In that case, press Host + C to toggle scale mode (where Host is Right Control by default)

  1. In the Guest system, go to the top menu, and click Devices->Insert Guest Additions CD Image. This should mount the CD image.
  2. In my case, Autostart worked, and the installation started with a prompt. If it doesn't autostart, you can do the following

    cd /media/<username>/VBOXADDITIONS_4.3.10_93012
    sudo ./VBoxLinuxAdditions.run

Just be sure to replace <username> by the logged in user's username.

And then a restart, as JTIM pointed out...

share|improve this answer
    
Thanks for your answer, +1 –  Sylvain Pineau Feb 28 at 21:33
2  
Well, it did enable 1024x768 for me, that's at least something. It still doesn't allow me to set anything higher though, despite trying all the other solutions. –  sp00n Mar 4 at 11:15
1  
I got it to work at any resolution following these steps. –  Antonio Mar 10 at 17:24
2  
Great update! I'm not sure all steps are necessary (dkms is already up-to-date if you first install virtual-guest-dkms), but it certainly worked for me! The virtual box window with Ubuntu now automatically scales to all resolutions. Oh, and I needed to exclude the virtualbox-guest-x11 in your first step. –  THelper Mar 19 at 13:56
1  
and then a restart :) –  JTIM Apr 8 at 10:08

Developing from this answer, and in fact pretty well explained also in this other post. (I really tried everything else posted here but it does not seem to work on my Windows 7 system)

Preliminary steps:

  1. Make sure you have installed the latest version of Virtual Box(*). Be careful that if you ask Virtual Box to update to the latest version it might very likely declare being updated even if a newer version exists!

  2. It might be a good idea to start from a clean distribution, creating a new virtual machine, install there Ubuntu (I allowed to download updated packages from the network during installation), and cloning it before proceeding, so that if you have troubles you can avoid restarting from the very beginning.

  3. Install build-essential and linux-headers-generic packages. Apparently, it's also reccomended to install dkms, as "Running DKMS in the guest OS will keep Guest Additions installed after a guest kernel update".

How to:

  1. Start your virtual machine

  2. On Virtualbox menu -> Devices -> Insert Guest Additions CD image...

  3. From Ubuntu you should see a popup, allow the CD autorun to install the program. For me, like many times before, it said he could not find Linux headers but, this time, in the end everything went fine.
    If the autorun does not work, open a terminal (Ctrl+Alt+T), navigate to folder (usually /media/VBOXADDITIONS*) and run

    sh ./VBoxLinuxAdditions.run

  4. Shut down and then start again your virtual machine


(*) If, like me, with the new version of the Virtual Box you have trouble with network, take a look at this video (In short: use Bridged network, and select "allow VMs")

share|improve this answer
    
Excellent. Out of all the answers, this is the only one which worked for me, with Ubuntu 14.04.2 64 bit guest and Windows 7 host. –  Jon Bentley Mar 18 at 11:02
    
Awesome, this solution actually worked perfectly after trying many others! Thank you! –  Jason Ilicic Apr 19 at 13:20

I had the same problem. I fixed it by installing the guest additions as explained in the other answers and jacking the amount of video RAM in the settings as shown. MateConfig

share|improve this answer

To expand on what Sylvain Pineau said, typing sudo apt-get install virtualbox* is much easier (wildcards are accepted with apt-get).

share|improve this answer
1  
But it will install packages like virtualbox-source, virtualbox-dbg and older versions (such as virtualbox-2.2) depending on your ppa settings –  Sylvain Pineau Jan 26 at 20:02

protected by Sylvain Pineau Mar 10 at 17:59

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.