Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an R9 280X set up & it was previously running successfully.

Recently I installed latest drivers (both the beta & stable - not at same time) and ran the command.

sudo amdconfig --initial -f -adapter=all

This command is successful and it says that it found an unconfigured xorg and has configured it. Then I rebooted.

Then nothing. When Ubuntu boots it gets stuck at blank screen with cursor flashing in top left corner.

When I deleted xorg.conf and rebooted the system rebooted to GDM login successfully.

To fix this I have tried removing lightdm & GDM and reinstalling both to no effect.

The following is my xorg.conf file after running the command above:

Section "ServerLayout"
    Identifier     "aticonfig Layout"
    Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
EndSection

Section "Monitor"
    Identifier   "aticonfig-Monitor[0]-0"
    Option      "VendorName" "ATI Proprietary Driver"
    Option      "ModelName" "Generic Autodetecting Monitor"
    Option      "DPMS" "true"
EndSection

Section "Device"
    Identifier  "aticonfig-Device[0]-0"
    Driver      "fglrx"
    BusID       "PCI:3:0:0"
EndSection

Section "Screen"
    Identifier "aticonfig-Screen[0]-0"
    Device     "aticonfig-Device[0]-0"
    Monitor    "aticonfig-Monitor[0]-0"
    DefaultDepth     24
    SubSection "Display"
            Viewport   0 0
            Depth     24
    EndSubSection
EndSection

How do I get GDM or Lightdm to start automatically at boot up when xorg.conf is configured with the AMD drivers?

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.