Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I have a Lubuntu (now 14.04) installation. Recently, I logged in to find that the Wi-Fi icon had disappeared, and there was some sort of a keyboard icon in it's place. I have restarted multiple times, but it doesn't fix it. I can't find the same applet in the panel settings, and resetting the panel didn't help. When I try to manually start nm-applet, it starts, but prints a bunch of warnings to the console:

nm-applet-Message: using fallback from indicator to GtkStatusIcon

It then starts, using ugly icons for the Wi-Fi connectivity symbol.

What do I need to do to make it start correctly? Once it starts, why isn't it using the right icons?

share|improve this question

marked as duplicate by bain, Eric Carvalho, LnxSlck, waltinator, Eliah Kagan Jun 25 at 1:02

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Same problem for me. Besides the network manager icon doesn't appear even typing "nm-applet" under "Manual autostarted applications" as suggested... And this is a bug reported a lot of times in the past to Lubuntu developers... –  user271931 Apr 21 at 12:41
    
@pigeonkiller The problem turned out to be a Trusty glitch. See here: wiki.ubuntu.com/TrustyTahr/ReleaseNotes/Lubuntu#Applications –  Wasabi Fan Apr 25 at 0:50
    
    

1 Answer 1

up vote 11 down vote accepted

To fix the Network Manager not showing up on the panel issue, from the Lubuntu menu select Preferences > Default applications for LXSession, then click on the Autostart tab and under "Manual autostarted applications" type "nm-applet", then click the "+ Add" button on the left:

Now log out, log back in and you should see the Network Manager icon on the panel: http://www.webupd8.org/2014/04/fix-lubuntu-1404-network-manager.html

enter image description here

share|improve this answer
    
I was thinking about that, but if it's not working, isn't that just a patch, and not a fix? I think the problem isn't that it's not being run, but that it's failing and exiting when it's run. What normally runs it? Is it just listed in the startup list? –  Wasabi Fan Apr 20 at 20:21
    
What does this command tell you? ps aux | grep nm-apple that will let you know if it is running, but what I posted in my answer is a fix to a bug issue with lubuntu 14.04 where nm-applet does not show in the panel –  Wild Man Apr 20 at 20:24
    
OK... is this really a problem with Trusty? I had assumed I screwed something up. I'll test this as soon as it finishes what it's installing. –  Wasabi Fan Apr 20 at 20:43
    
I just tested this, and it got it to show up. But the icon still looks wrong; why can't it find the right icons? –  Wasabi Fan Apr 20 at 21:00
    
It may be because of the bug or did you do an upgrade instead of a fresh install? I really do not have a fix for that, I am glad it is showing up now, please accept the answer to help other people since the icon is no longer missing. I suggest starting a new question just for the ugly icon issue. Thanks –  Wild Man Apr 20 at 21:57

protected by Community Apr 24 at 10:16

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.