Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a small issue with libc6 package. There is some output:

root@xubuntu:/# aptitude versions libc6
Package libc6:                        
p   2.17-93ubuntu4  saucy   500 
H   2.18-4                  100 

root@xubuntu:/# aptitude show libc6
Package: libc6                           
State: partially installed
Automatically installed: no
Multi-Arch: same
Version: 2.18-4
Priority: required
Section: libs
Maintainer: GNU Libc Maintainers <debian-glibc@lists.debian.org>
Architecture: amd64
Uncompressed Size: 10.5 M
Depends: libgcc1
Suggests: glibc-doc, debconf | debconf-2.0, locales
Conflicts: prelink (<= 0.0.20090311-1), prelink (<= 0.0.20090311-1), tzdata (< 2007k-1), tzdata (< 2007k-1), tzdata-etch, tzdata-etch
Breaks: hurd (< 1:0.5.git20140203-1), hurd (< 1:0.5.git20140203-1), locales (< 2.18), locales (< 2.18), locales-all (< 2.18), locales-all (< 2.18), lsb-core (<=
    3.2-27), lsb-core (<= 3.2-27), nscd (< 2.18), nscd (< 2.18), libc6 (!= 2.18-4)
Replaces: libc6-amd64, libc6-amd64, libc6 (< 2.18-4)
Provides: glibc-2.18-1
Description: Embedded GNU C Library: Shared libraries
 Contains the standard libraries that are used by nearly all programs on the system.     This package includes shared versions of the standard C library and the standard math library, as well as many others.
Homepage: http://www.eglibc.org

root@xubuntu:/# aptitude reinstall libc6
The following packages will be REINSTALLED:
  libc6 libc6:i386 
0 packages upgraded, 0 newly installed, 2 reinstalled, 0 to remove and 26 not upgraded.
Need to get 0 B of archives. After unpacking 0 B will be used.
E: I wasn't able to locate a file for the libc6 package. This might mean you need to manually fix this package.
E: I wasn't able to locate a file for the libc6 package. This might mean you need to manually fix this package.
E: Internal error: couldn't generate list of packages to download

I suppose I need to uninstall version 2.18-4 without removing dependencies and older package version. So, how to do it?

share|improve this question
add comment

1 Answer 1

You can use apt-get to install a specific version of the package a long as it is in an archive that apt knows about. From the apt-get manpage:

A specific version of a package can be selected for installation by following the package name with an equals and the version of the package to select. This will cause that version to be located and selected for install. Alternatively a specific distribution can be selected by following the package name with a slash and the version of the distribution or the Archive name (stable, frozen, unstable).

For example, you could do:

sudo apt-get install apache2=2.2.20-1ubuntu1 Note that you may need to do some dependency resolution on your own in this case, but if there are any problems apt-get will tell you what is causing them. On my 11.10 system I would need to do the following to get this to work:

sudo apt-get install apache2=2.2.20-1ubuntu1 \ apache2.2-common=2.2.20-1ubuntu1 \ apache2.2-bin=2.2.20-1ubuntu1 \ apache2-mpm-worker=2.2.20-1ubuntu1'

Original Answer: How to install specific Ubuntu packages, with exact version?

share|improve this answer
    
Thanks but I need to remove newer version, not to install old. I already have two versions of libc6, and I need to downgrade from newer to older. –  Everv0id Apr 20 at 16:58
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.