Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Firstly, this is not a Unity question, I'm a Ubuntu 'Classic'™ user!

What really annoys me is that everytime I open an office document the libre office writer doesn't appear on the current workspace, but on the one on the left or right. I really don't know where this comes from, but it is a really weird behavior as this only happens to libreoffice writer windows, for instance, presentations are not affected.

For example: I run 4 workspaces which look like this:

| 1 | 2 |
| 3 | 4 |

If nautilus is on workspace 1, libreoffice writer opens on workspace 2 and vice versa.

If nautilus is on workspace 3, libreoffice writer opens on workspace 4 and vice versa.

I did have a look at the compiz config settings manager, but toggling a few plugins did not help.

Thanks in advance!

share|improve this question
up vote 0 down vote accepted

you can go to ccsm, in the place window plugin, you should find an option "placement mode". set it to centred. hope this will do. Edit: make sure that the plugin "place window" is checked. go to the second tab, which is fixed window placement. then go to "windows with fixed viewport". there you can grab an application and force it to be opened always in the workspace you choose. that can be a workaround. source:

share|improve this answer
sadly it changes nothing :/ – phineas May 25 '11 at 17:43
see updated answer. and tell me if it worked – suli8 May 25 '11 at 20:35
nope this won't work either. But I discovered another thing: If you open libreoffice writer from the menu bar, it will open on same workspace. When opening from Nautilus (or the desktop) it won't. Do you think reinstalling it will change sth? – phineas May 26 '11 at 8:14
A cheap workaround is to remove the second column of workspaces. Maybe I'll just accept that as a solution. – phineas May 26 '11 at 8:16
it is strange that even the fixed viewport doesn't do anything. i have no more ideas. you may need to report a bug on launchpad. – suli8 May 26 '11 at 14:59

This is a bug in LibreOffice, and I have reported it in Launchpad. Workaround: Unmaximize the Writer -window before closing the application.

Please go to that bug and select "Yes, this bug affects me"

There is also a similar bug reported earlier, which is about LibreOffice Writer opening in a wrong workspace after closed while maximized. Please subscribe to that as well.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.