Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm quite new to Ubuntu... Right now I'm using 14.04 Trusty Tahr, and I love it...

Except for one thing... The display driver. I want the best performance I can get from my video card (ATi Radeon HD 3600). I know, I know, it's not a powerful card, but with the Gallium driver it seems like I won't be able to play any games. And don't get me wrong, I don't want to play AAA games, I was hoping to play Team Fortress II and that kind of stuff...

Now to get to the point.

I've downloaded the latest display driver (13.1) for my card from AMD site. I've tried running the .run file in terminal, and when I chose to install the driver, a message popped out saying that one or more packages required for installation have not been found.

Then I did the following:

sudo sh (drivername).run --buildpkg Ubuntu/trusty

After that, I installed the .deb package that was generated (don't remember the command). Before the reboot, I entered

aticonfig --initial

After reboot, I was not logged in my account, instead I was at the login screen. Entering my password would bring me back to the login screen, not even Guest account works.

So I had to remove the driver by pressing Ctrl+Alt+F1, and then everything worked.

sudo apt-get remove fglrx

So here are some commands I tried before removing the driver (none of them worked)

sudo mv ~/.Xauthority ~/.Xauthority.backup
sudo service lightdm restart

sudo chown -r $USER:$USER $HOME

cd /tmp
sudo rm -Rf *

ls -lah
chown username:username .Xauthority
sudo chmod a+wt /tmp

dpkg-reconfigure lightdm

sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.backup

ls -l ~/.Xauthority

When I typed in ls -lah, some packages got listed, and 3 of them (all have fglrx in their names) were written in red instead of white.

Also, I'm using 64 bit Ubuntu. So if you have any other commands I can try, please let me know.

share|improve this question

1 Answer 1

To correctly uninstall fglrx you had to run:

sudo amdconfig --uninstall

As I can read from your question, you just did a apt-get remove fglrx which, if I remember correctly, it's not enough to completely remove the driver from the system. Remove everything that's still on your system using:

sudo sh /usr/share/ati/fglrx-uninstall.sh
sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev*

AMD's description of the driver:

Automated installer and Display Drivers for Xorg 6.9 to Xserver 1.12 and Kernel version up to 3.4

If I don't get wrong, Ubuntu 14.04LTS has:

  • X server version 1.15
  • Kernel version 3.13

Because of this, you can't install the driver. Kernel and X versions are not supported.

Users will probably make a patch to let them work on 14.04 too (as they did with Ubuntu 13.10), but as fair as I know, at the moment there is no patch.

Moreover, AMD is not releasing updates for legacy driver, so I really suggest you to use the open-source driver (installed by default) for your video card. (I'm using it too on my 2nd PC where I have an HD 4650).

About playing using the open driver, what problem are you having?

A lot of users says that installing S2TC texture compression and conversion tools helps a lot with games.
You can try it by installing the packages using:

sudo apt-get install libtxc-dxtn-s2tc0
sudo apt-get install libtxc-dxtn-s2tc0:i386
share|improve this answer
    
After removing the fglrx driver, I got back on the default one, but it's not the same... It says Gallium and then some weird stuff, and every animation on screen is laggy. Can I downgrade Xserver or kernel version? –  Dario Apr 20 at 11:45
    
I've update my answer, adding how to remove fglrx from your system. About downgrading X and Kernel version, I don't suggest you to do this. At least you can wait for a patch to let you use the driver. –  PeppeDAlterio Apr 20 at 11:59
    
Thanks, I'll give it a try... Can I re-install the default drivers somehow? –  Dario Apr 20 at 12:13
    
Your system should automatically use them after fglrx uninstall. –  PeppeDAlterio Apr 20 at 14:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.