Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I made a fresh installation of Ubuntu 14.04 and then decided to try Gnome and installed its packages. I didn't like it and came back to using to Unity.

After this experiment the notifications became messed up. For the text messages they appeared in the plain text mode without any borders, in a plain rectangle in the different part of the screen. Also the notifications of the change of volume and brightness are also gone. Where can I restore them? I checked the content of:

/usr/share/dbus-1/services/org.freedesktop.Notifications.service

[D-BUS Service]
Name=org.freedesktop.Notifications
Exec=/usr/lib/x86_64-linux-gnu/notify-osd
share|improve this question

2 Answers 2

You shouldn't really be using unity notifications with GNOME anyway. GNOME has it's own notifications system. You need to use that.

The concept is that you either use:

GNOME

Unity

KDE

XFCE

LDXE

Although there is a little crossover here and there, the messaging systems tend to be built into the compositor most of the time.

EDIT: this is not exactly an answer but it was too long for the comment, sorry. I had not realised I already posted one.

In short. There's not enough information to make it possible to help at the moment. It could be anything really.

Do you know how to get a stacktrace with gdb? It's worth getting one and posting it in a paste to here so people can take a look at the problem.

If you are not sure how to use gdb a quick check of the logs is to run:

/var/log | grep -rn "(EE)"

then try the same replacing "(EE)" with with "(WW)" and failed should mean something useful comes up for one of these. Then it will be easier to answer the question.

You may also wish to check synaptic package manager under 'broken' packages just in case something comes up there

EDIT:

It is still hard to tell without knowing more of the problem but, what it seems like is that you are still missing some sort of dependency. So, in that case try this:

sudo apt-get build-deps unity

and other unity related stuff you need (sorry I don't use unity so I would not know the usual list a person normally installs to complete the environment but at a guess I'd say there's an associated control center, compositor, display manager: things like that).

share|improve this answer
    
I probably didn't make it clear enough that I came back to Unity and notifications are still broken. –  SimpleMan Apr 20 at 7:09
    
@SimpleMan try the edit out. –  Magpie Apr 27 at 1:51

It seems there is no priority or a single setting point to set which freedesktop notification daemon to run. I got such problem with XFCE installed on Ubuntu 14.04.

Unity notification launch xfce4-notifyd (XFCE styled notifications) as it was the default.

  • Check for available notification services, example:

    $ grep -r org.freedesktop.Notifications /usr/share/dbus-1/services/
    /usr/share/dbus-1/services/org.xfce.xfce4-notifyd.Notifications.service:Name=org.freedesktop.Notifications
    /usr/share/dbus-1/services/org.freedesktop.Notifications.service:Name=org.freedesktop.Notifications
    
  • Disable non needed ones, leave only the one you want, add a name extension suffix .disable:

    sudo mv /usr/share/dbus-1/services/org.xfce.xfce4-notifyd.Notifications.service /usr/share/dbus-1/services/org.xfce.xfce4-notifyd.Notifications.service.disable
    
    pkill xfce4-notifyd
    
  • Check

    notify-send test
    

If there is no Gnome service file /usr/share/dbus-1/services/org.gnome.Notifications.service. Try adding notify-osd to Upstart Application. See How do I start applications automatically on login?.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.