Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I'm trying to upgrade from 12.04 to 14.04 and am encountering problems.
I'm working from 12.04. Downloaded the 14.04 iso file. Used the Startup Disc Creator App.

However, when I try to boot from USB, I get a "Boot error" message.
I've tried booting with the USB drive in all 4 USB ports. I've reformatted the USB drive. I've re-downloaded the iso file. Keep getting the same results.

Frustrating because it worked fine when I loaded 12.04 using this same procedure on the same computer (Toshiba Satellite with AMD 64 processor).

share|improve this question

marked as duplicate by bain, Radu Rădeanu, Eric Carvalho, psusi, Jorge Castro Jul 9 at 14:51

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2 Answers 2

I would perform a MD5 check to make sure the .ISO file you are downloading is good. The procedure is here: https://help.ubuntu.com/community/HowToMD5SUM (do the manual procedure its fast and easy).

The 14.04 MD5 value is here: http://releases.ubuntu.com/trusty/MD5SUMS

I have never installed using a usb, and have aways used a DVD disk. It's really easy if it's an option for you. If using a USB is important to you, take a look here to make sure what you are doing is the same as the 14.04 bootable USB procedure: https://help.ubuntu.com/community/Installation/FromUSBStick

Lastly, make sure that your bios boot order allows your boot device to be the highest in the list; or manually select where to boot from when your PC starts.

If it worked on a 12.04 install, it is a good sign! Just keep digging, you'll get it.

share|improve this answer
up vote 0 down vote accepted

Got 14.04 on the system without having to re-install using USB stick.
Found this link with instructions on how to upgrade directly from within 12.04.

Here are the steps:

Make sure all updates are installed. Open a terminal screen Type sudo update-manager -d An update window pop-up window should appear with an option at the top to upgrade to 14.04.

Worked perfectly for me.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.