Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've a following problem - I've just upgraded from 13.10 to 14.04 on my Dell Vostro 3350 and I can't turn off the discrete graphics. As instructed here and following HybridGraphics I managed to permanently turn off my secondary Radeon graphics in 13.10, though now the same operation doesn't work. After enabling the vgaswitheroo and typing in terminal cat /sys/kernel/debug/vgaswitcheroo/switch output looks like this

0:IGD:+:Pwr:0000:00:02.0
1:DIS: :DynOff:0000:01:00.0

instead of

0:DIS: :Off:0000:01:00.0
1:IGD:+:Pwr:0000:00:02.0 

I saw in 13.10. The effect is exactly the same as if discrete graphics is on, laptop is loud and terribly overheats. Typing sudo echo OFF > /sys/kernel/debug/vgaswitcheroo/switch gives no effect, output of cat /sys/kernel/debug/vgaswitcheroo/switch doesn't change. I tried some additional commands, like suggested in this post, didn't help thought. 14.04 installation is brand new, this was the first thing I tried to set up, so my guess I miss something, no idea what though. I would appreciate some help with this issue, as it increases temperatures detected by sensors by almost 20 degrees compared to those with discrete graphics off, which, well, is defiantly not good for the hardware.

Thanks!

share|improve this question
    
try this askubuntu.com/a/451021/202806 –  Avinash Raj Apr 20 at 0:51
    
Doesn't work. echo OFF > /sys/kernel/debug/vgaswitcheroo/switch exit 0 in rc.local gives 0:DIS: :DynOff:0000:01:00.0 1:IGD:+:Pwr:0000:00:02.0 no changes. –  Voii Apr 20 at 9:01
    
but it's an accepted answer askubuntu.com/a/89213/202806 –  Avinash Raj Apr 20 at 9:03
    
Yes it is, not for 14.04 though. As I wrote, I knew how to do this before, it worked for me on 13.10, now it doesn't work anymore. –  Voii Apr 20 at 12:05
    
I am having a similar problem with an Acer Aspire 5820TG laptop (Intel / Radeon 5650) after the upgrade. However the DynOff condition is not a problem for overheating in my case. The only annoying thing is that X.org connects to this card as a screen which powers up the card and I have to disable it using arandr. –  Nanite May 4 at 12:01

3 Answers 3

on the arch forum https://bbs.archlinux.org/viewtopic.php?pid=1301253 I have found working xorg.conf which helps me. Now power consumption of my notebook is 10.7W instead of 12.6W in Ubuntu 14.04

share|improve this answer
2  
Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Eric Carvalho Jul 24 at 21:23

" saw in 13.10. The effect is exactly the same as if discrete graphics is on, laptop is loud and terribly overheats. Typing sudo echo OFF > /sys/kernel/debug/vgaswitcheroo/switch gives no effect, output of cat /sys/kernel/debug/vgaswitcheroo/switch doesn't change."

from my experience, DynOff works better than manual Off. It still says Off (DynOff) and I guess that it means the card is not powered and that this is automatic.

However, if you still want to roll things back to the manual settings, you have to modify grub. Use sudo to do the following:

open in any editor the file /etc/default/grub and find the line

GRUB_CMDLINE_LINUX_DEFAULT=

there should be values like "quiet splash" in this line; just add radeon.runpm=0 so it looks something like this:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.runpm=0"

save the file and run

sudo update-grub

then reboot. after rebooting, the behavior of cat /sys/kernel/debug/vgaswitcheroo/switch should be like in older ubuntu version. then you can run

echo OFF > /sys/kernel/debug/vgaswitheroo/switch

to see if it works - as you used to do before. if it works, add this line to /etc/rc.local just above exit 0.

i tried it on my machine and it basically works... but i think that DynOff is doing exactly the same. my computer is not overheating with both configurations.

share|improve this answer

Try this and confirm in comments if this works...

http://www.mostthingsweb.com/2014/07/disable-radeon-power-management-newer-linux-kernels/.

For me, during first reboot it gave a low graphics mode. Then, I pressed Ctrl+Alt+F2, and then ran the cat /sys/kernel/debug/vgaswitcheroo/switch, where it showed "Off" infront of DIS. Then, I ran sudo shutdown now -r to reboot. Finally,in the next reboot it worked. Also, I edited the etc/rc.local file to make this change permanent. Although I used Ubuntu 12.04.5, but I used the latest kernel 3.13...which, I believe, is the source of the problem, due to the recent changes in discrete graphics handling method.

share|improve this answer
    
Sorry, I cannot confirm anymore, I got rid of the equipment months ago... –  Voii Nov 9 at 15:51
    
@Voii Well, it works pretty nice for me. There were some problems with Linux 3.13.0-39. However after trying on a fresh install in Ubuntu, I realized may be this was due to Intel Open Source driver as it worked pretty nice. This in combination with tlp and webupd8.org/2014/04/prevent-your-laptop-from-overheating.html works fantastic for me. Anyways, thanks for commenting. :) –  Player Nov 14 at 14:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.