Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

With KMS enabled on Xubuntu 11.04, my virtual terminals are running at 60hz, the default for my monitor, while my X desktop is running at 75, the refresh rate I specified in my xorg.conf. How do I set the refresh rate/mode used by KMS so that it is something different from the default mode provided by my monitor?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

You can specify the resolution/refresh rate that the VT framebuffers will use on the kernel command line¹.

To do so, you want to add

video=<xres>x<yres>@<refresh>

to your kernel command line. So, for example

video=1024x768@75

would give you a 1024x768 framebuffer at 75Hz. The @<refresh> bit is optional.

You can edit your kernel command line on a one-time basis by hitting e from the grub menu, or to set it permanently you can edit /etc/default/grub, adding it to the line

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

like so:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash video=1024x768@75"

After editing /etc/default/grub you'll need to run sudo update-grub to propagate the configuration to your boot settings.

Documentation/fb/modedb.txt has the full specification of what options you can pass in to video= - if you have unusual requirements (interlaced, reduced-blanking, etc) see this documentation.

¹: This is due in part to the fact that there's no good way to notify VT users of resolution changes.

share|improve this answer
1  
Notes to future readers as nooby as me: Add the video option to the GRUB_CMDLINE_LINUX_DEFAULT option, as such: GRUB_CMDLINE_LINUX_DEFAULT="video=1280x1024@75 quiet splash" Be sure to run update-grub. –  raevol May 27 '11 at 9:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.