Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

There is Settings > Keyboard > Layout and there is something called iBus and input methods.

I were using Keyboard > Layout GUI to configure my layouts in 13.10 and it worked fine. But after update to 14.04 something called iBus appeared and now my shortcut Alt+Shift is not working. Looks like something is intercepting this hotkey. If I set hotkey to something else in Keyboard > Layout it's working: I can change my layout, but if I set it to Alt+Shift it's not working at all.

What are those different methods of keyboard input configuration? What method is preferred? How do I enable only one preferred method and disable another one in order to prevent conflicts?

There is iBus icon on the panel. When I click on it, a drop-down menu appears with two input methods. But when I select one of them, nothing happens. The input language is still the same.

Please advise. Thank you!

share|improve this question

2 Answers 2

I had problems using my ASUS EeePC 1015PX with Xubuntu 14.04 defaulting to the European keyboard layout, so every time I logged in I had to change it in Terminal.

But now, until the bug is fixed, you can create a start-up script in Xubuntu so it configures to whatever you want on log in (and considering my laptop suffers from the black screen after sleep bug, I am shutting down and logging in a lot these days!)

Menu >> Settings Manager >> System >> Session and Startup >> tab Application Autostart

Click +Add button, then fill in the three boxes as follows:

Name: USKeyboard (or call it whatever you want)

Description: Change keyboard layout to US on login.

Command: setxkbmap -layout us

Click OK

Reboot and test your keyboard (for me, that means making sure SHIFT-2 gives @ and not " and vice versa, as well as some other character changes such as |).

You will have to google the abbreviation for other regions' keyboard layouts but the principle should be the same. Once you find out the abbreviations, you can change the layout in Terminal using the setxkbmap -layout command, appended with the region's code, whenever you want, but with each reboot it will default back to whatever you chose in your startup script.

share|improve this answer
    
Thanks for your contribution! I'm not sure it directly answers my question, but I believe others will benefit from it. –  Slava Fomin II Apr 25 at 5:23
up vote 0 down vote accepted

I'm not sure what all the technical details behind all of this, but here's the method you can use to configure multiple keyboard layouts in latest Xubuntu 14.04.

  1. Open Settings Manager
  2. Launch Input Method
  3. Hit OK and/or Yes
  4. Select None from the list of input methods and click OK probably several times
  5. Open Keyboard Input Methods
  6. In the Keyboard Shortcuts section remove all the keys associated with Next input method command
  7. Open Keyboard, select Layout tab and configure your layouts and shortcuts

In case there is no "Keyboard Input Methods"

  1. Open All Settings
  2. Choose Input Method
  3. Hit OK and/or Yes if you asked (probably several times)
  4. Chose REMOVE
  5. Hit OK and/or Yes until window is closed
  6. Open Keyboard, select Layout tab and configure your layouts and shortcuts

It should work fine now.

share|improve this answer
1  
Keep an eye on bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/… too... –  Rmano May 8 at 16:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.