Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a tablet with Android on which I installed ES File Explorer so that I can access files on my PC with Ubuntu. I do this using the Samba protocol.

It works fine when I use my administrator account when defining the new server in ES File Explorer. I can see and access all files.

Using the Samba program under Ubuntu, I defined another Samba user and gave this user permission to access dir1. Trying to access dir1 from my tablet with the corresponding credentials, I get the error Login fails. This may be caused by: - The account has no permissions.

Looking at the permission of dir1 with ls -l, I get drwxr-xr-x, which is correct, I believe.

What am I doing wrong?

My smb.conf:

[global]
    workgroup = <<WORKGROUP>>
    server string = %h server (Samba, Ubuntu)
    dns proxy = no
    log file = /var/log/samba/log.%m
    max log size = 1000
    syslog = 0
    panic action = /usr/share/samba/panic-action %d


####### Authentication #######

# "security = user" is always a good idea. This will require a Unix account
# in this server for every user accessing the server. See
# /usr/share/doc/samba-doc/htmldocs/Samba3-HOWTO/ServerType.html
# in the samba-doc package for details.
#   security = user

# You may wish to use password encryption.  See the section on
# 'encrypt passwords' in the smb.conf(5) manpage before enabling.
;   encrypt passwords = yes

# If you are using encrypted passwords, Samba will need to know what
# password database type you are using.  
;   passdb backend = tdbsam

    obey pam restrictions = yes

# This boolean parameter controls whether Samba attempts to sync the Unix
# password with the SMB password when the encrypted SMB password in the
# passdb is changed.
    unix password sync = yes

# For Unix password sync to work on a Debian GNU/Linux system, the following
# parameters must be set (thanks to Ian Kahan <<[email protected]> for
# sending the correct chat script for the passwd program in Debian Sarge).
    passwd program = /usr/bin/passwd %u
    passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .

# This boolean controls whether PAM will be used for password changes
# when requested by an SMB client instead of the program listed in
# 'passwd program'. The default is 'no'.
    pam password change = yes

# This option controls how unsuccessful authentication attempts are mapped
# to anonymous connections
    map to guest = bad user

########## Domains ###########

# Is this machine able to authenticate users. Both PDC and BDC
# must have this setting enabled. If you are the BDC you must
# change the 'domain master' setting to no
#
;   domain logons = yes
#
# The following setting only takes effect if 'domain logons' is set
# It specifies the location of the user's profile directory
# from the client point of view)
# The following required a [profiles] share to be setup on the
# samba server (see below)
;   logon path = \\%N\profiles\%U
# Another common choice is storing the profile in the user's home directory
# (this is Samba's default)
#   logon path = \\%N\%U\profile

# The following setting only takes effect if 'domain logons' is set
# It specifies the location of a user's home directory (from the client
# point of view)
;   logon drive = H:
#   logon home = \\%N\%U

# The following setting only takes effect if 'domain logons' is set
# It specifies the script to run during logon. The script must be stored
# in the [netlogon] share
# NOTE: Must be store in 'DOS' file format convention
;   logon script = logon.cmd

# This allows Unix users to be created on the domain controller via the SAMR
# RPC pipe.  The example command creates a user account with a disabled Unix
# password; please adapt to your needs
; add user script = /usr/sbin/adduser --quiet --disabled-password --gecos "" %u

# This allows machine accounts to be created on the domain controller via the 
# SAMR RPC pipe.  
# The following assumes a "machines" group exists on the system
; add machine script  = /usr/sbin/useradd -g machines -c "%u machine account" -d /var/lib/samba -s /bin/false %u

# This allows Unix groups to be created on the domain controller via the SAMR
# RPC pipe.  
; add group script = /usr/sbin/addgroup --force-badname %g

########## Printing ##########

# If you want to automatically load your printer list rather
# than setting them up individually then you'll need this
#   load printers = yes

# lpr(ng) printing. You may wish to override the location of the
# printcap file
;   printing = bsd
;   printcap name = /etc/printcap

# CUPS printing.  See also the cupsaddsmb(8) manpage in the
# cupsys-client package.
;   printing = cups
;   printcap name = cups

############ Misc ############

# Using the following line enables you to customise your configuration
# on a per machine basis. The %m gets replaced with the netbios name
# of the machine that is connecting
;   include = /home/samba/etc/smb.conf.%m

# Most people will find that this option gives better performance.
# See smb.conf(5) and /usr/share/doc/samba-doc/htmldocs/Samba3-HOWTO/speed.html
# for details
# You may want to add the following on a Linux system:
#         SO_RCVBUF=8192 SO_SNDBUF=8192
#   socket options = TCP_NODELAY

# The following parameter is useful only if you have the linpopup package
# installed. The samba maintainer and the linpopup maintainer are
# working to ease installation and configuration of linpopup and samba.
;   message command = /bin/sh -c '/usr/bin/linpopup "%f" "%m" %s; rm %s' &

# Domain Master specifies Samba to be the Domain Master Browser. If this
# machine will be configured as a BDC (a secondary logon server), you
# must set this to 'no'; otherwise, the default behavior is recommended.
#   domain master = auto

# Some defaults for winbind (make sure you're not using the ranges
# for something else.)
;   idmap uid = 10000-20000
;   idmap gid = 10000-20000
;   template shell = /bin/bash

# The following was the default behaviour in sarge,
# but samba upstream reverted the default because it might induce
# performance issues in large organizations.
# See Debian bug #368251 for some of the consequences of *not*
# having this setting and smb.conf(5) for details.
;   winbind enum groups = yes
;   winbind enum users = yes

# Setup usershare options to enable non-root users to share folders
# with the net usershare command.

# Maximum number of usershare. 0 (default) means that usershare is disabled.
;   usershare max shares = 100

# Allow users who've been granted usershare privileges to create
# public shares, not just authenticated ones
    usershare allow guests = yes
    username map = /etc/samba/smbusers
    security = user
;   guest ok = no
;   guest account = nobody

#======================= Share Definitions =======================

# Un-comment the following (and tweak the other settings below to suit)
# to enable the default home directory shares. This will share each 
# user's home director as \\server\username
;[homes]
;   comment = Home Directories
;   browseable = no

# By default, the home directories are exported read-only. Change the
# next parameter to 'no' if you want to be able to write to them.
;   read only = yes

# File creation mask is set to 0700 for security reasons. If you want to
# create files with group=rw permissions, set next parameter to 0775.
;   create mask = 0700

# Directory creation mask is set to 0700 for security reasons. If you want to
# create dirs. with group=rw permissions, set next parameter to 0775.
;   directory mask = 0700

# By default, \\server\username shares can be connected to by anyone
# with access to the samba server. Un-comment the following parameter
# to make sure that only "username" can connect to \\server\username
# The following parameter makes sure that only "username" can connect
#
# This might need tweaking when using external authentication schemes
;   valid users = %S

# Un-comment the following and create the netlogon directory for Domain Logons
# (you need to configure Samba to act as a domain controller too.)
;[netlogon]
;   comment = Network Logon Service
;   path = /home/samba/netlogon
;   guest ok = yes
;   read only = yes

# Un-comment the following and create the profiles directory to store
# users profiles (see the "logon path" option above)
# (you need to configure Samba to act as a domain controller too.)
# The path below should be writable by all users so that their
# profile directory may be created the first time they log on
;[profiles]
;   comment = Users profiles
;   path = /home/samba/profiles
;   guest ok = no
;   browseable = no
;   create mask = 0600
;   directory mask = 0700

[printers]
    comment = All Printers
    browseable = no
    path = /var/spool/samba
    printable = yes
;   guest ok = no
;   read only = yes
    create mask = 0700

# Windows clients look for this share name as a source of downloadable
# printer drivers
[print$]
    comment = Printer Drivers
    path = /var/lib/samba/printers
;   browseable = yes
;   read only = yes
;   guest ok = no
# Uncomment to allow remote administration of Windows print drivers.
# You may need to replace 'lpadmin' with the name of the group your
# admin users are members of.
# Please note that you also need to set appropriate Unix permissions
# to the drivers directory for these users to have write rights in it
;   write list = root, @lpadmin

# A sample share for sharing your CD-ROM with others.
;[cdrom]
;   comment = Samba server's CD-ROM
;   read only = yes
;   locking = no
;   path = /cdrom
;   guest ok = yes

# The next two parameters show how to auto-mount a CD-ROM when the
#   cdrom share is accesed. For this to work /etc/fstab must contain
#   an entry like this:
#
#       /dev/scd0   /cdrom  iso9660 defaults,noauto,ro,user   0 0
#
# The CD-ROM gets unmounted automatically after the connection to the
#
# If you don't want to use auto-mounting/unmounting make sure the CD
#   is mounted on /cdrom
#
;   preexec = /bin/mount /cdrom
;   postexec = /bin/umount /cdrom

[<<dir1>>]
    path = <<dir1>>
    writeable = yes
;   browseable = yes
    valid users = <<user_all_access>>

[<<dir2>>]
    path = <<dir2>>
;   writeable = no
;   browseable = yes
    valid users = <<user_limited_access>>
share|improve this question

migrated from android.stackexchange.com Apr 19 at 13:15

This question came from our site for enthusiasts and power users of the Android operating system.

    
I ran into the same problem but curiously different directories had different access. My home directory I could access fine, but shared directories didn't. The password reset / samba restart worked well. Curiously this was the case even when all permissions were set to open access. Anyone care to explain what was going on that this works? –  Richard Sep 17 at 2:52

2 Answers 2

The best solution is to use SFTP instead of SMB/CIFS. There is no reason to be using a samba protocol when both systems are Linux based.

ES File Explorer fully supports SFTP. You can configure it by choosing "FTP" under Network menu, then selecting "New" followed by SFTP.

share|improve this answer
    
Indeed, I could use the FTP for file sharing. But then I'd have to set up a FTP server on my PC, so that I can access it with the ES File Explorer client from my tablet. Which FTP server program with GUI for Ubuntu do you recommend? Nonetheless, I think the solution should be much less cumbersome. As I said, accessing my PC with an administrator account already works fine, but I want to give another user limited access. So there's nothing wrong with Samba, but I can't seem to get the account working. Furthermore, an advantage of Samba over FTP is that it's always activated under Ubuntu. –  Adriaan Apr 21 at 11:30
    
SFTP uses the ssh protocol, and there is no extra setup needed other than for OpenSSH to be installed. sudo apt-get install openssh-server –  nullmem Apr 21 at 16:27
    
Originally this post was in the Android forum, so my answer was intended to resolve the problem from the perspective of an Android user. If you provide some additional information, such as your smb.conf I will update my answer to include correct Samba configuration for use with your Android device. With that said, I maintain the best solution is to use SFTP, as it is more secure and easier to setup. –  nullmem Apr 21 at 16:37
    
I see that indeed OpenSSH is sufficient. I already used it before, and I agree with you that it is the most secure and easy way. It is unfortunately a factor 5 slower than Samba :(, which is why I still prefer Samba for watching video on my tablet over the WLAN. I just attached my smb.conf. –  Adriaan Apr 21 at 18:10
    
If you provide some additional information, such as your smb.conf I will update my answer to include correct Samba configuration for use with your Android device. I added the smb.conf, as you requested. The question is still open. Can you perhaps still help me out nullmem? Thanks in advance! –  Adriaan Apr 29 at 7:16

I found a solution in http://techtalk.shieldsgroup.com/2014/05/es-file-explorer-cant-find-ubuntu-server/ that worked for me, after having tried a lot of other suggested solutions.

The solution on the techtalk site suggest basically installing samba on Ubuntu (which I already had installed) and adding your userid as a samba user and restarting samba (which I did).

Open a terminal and enter:

sudo smbpasswd -a username
sudo service smbd restart

That did the trick

share|improve this answer
    
I found that disabling SELinux made it work. –  Octopus Jun 23 at 4:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.