Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have updated my 12.04 HTPC to 14.04 (new install; same hardware), and have started getting awful screen tearing where I had none before.

/proc/cpuinfo

AMD A4-3300 APU with Radeon(tm) HD Graphics

lspci

...

01:00.0 VGA compatible controller: NVIDIA Corporation GT218 [GeForce 210] (rev a2)

...

lsmod

...

nvidia 10675249 71

drm 302631 2 nvidia

...

Everything is from the official repos.

xbmc_12.3+dfsg1-3ubuntu1_all.deb

nvidia-331_331.38-0ubuntu7_amd64.deb

share|improve this question
    
can you add an image to show what this is about? next: ANY weird behaviour regarding artifacts should be a -bug-. So best option would be to file a bug against the corresponding package –  Rinzwind Apr 19 at 12:43
    
Confirmed for working. Using Ubuntu 14.04 , XBMC 12.3 , and nVIDIA 331.38. (GT440) –  user271129 Apr 19 at 19:36
    
Thank you! install libsdl1.2debian from Timo Jyrinki repo solved it for me too with kde and amd apu 8670D –  user276189 Apr 30 at 9:19
    
I tried both suggestions of adding the -bs as well as enabling that libsdl ppa and neither made my screen tearing go away. Playing minecraft I have major screen tearing when running up and down stairs. I am using a GTX 760 with Nvidia Binary BLOB 337.25. VSync is enabled within the game. Sync to VBlank is also enabled within the nvidia-settings so if anyone else has any other suggestions please let me know, this screen tearing is driving me through the roof! –  user216840 May 31 at 21:02

5 Answers 5

up vote 10 down vote accepted

I too had this problem after upgrading to 14.04

The solution mentioned here worked wonders for me,

https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/1278012/comments/12

A workaround for ubuntu 14.04 with nvidia driver is to disable backing store in xorg: Make sure you have the "-bs" option in lightdm config file:

cat /usr/share/lightdm/lightdm.conf.d/50-xserver-command.conf
[SeatDefaults]
# Dump core
xserver-command=X -bs -core

If you're using another mechanism for starting X you can use the same flag in a similar way. For example, here's startx which is popularly used in XBMC (and other kiosk applications') startup scripts:

startx /etc/X11/Xsession /usr/bin/xbmc-standalone -- -bs
share|improve this answer
    
Perfect. I've added what I needed to do to pass this along to X with startx. Thanks. –  Oli Apr 19 at 16:24
1  
Awesome thanks! Note, this also fixes it for Intel graphics cards (my onboard i3) –  SCdF Apr 20 at 7:40
    
It solved my problem too, with intel ivybridge. Thanks ! –  Toilal Apr 27 at 17:52

Just to sum up to the Brenden's answer, the real problem is with the libsdl1.2 package, as stated in this bug report.

The solution is ready, but somehow isn't available on default Ubuntu package sources yet (at least not for me). So, a way to solve this is to import the developer PPA and install the patched package directly:

sudo apt-add-repository ppa:timo-jyrinki/ppa
sudo apt-get update
sudo apt-get install libsdl1.2debian

You can later remove the PPA with:

sudo apt-get install ppa-purge
sudo ppa-purge ppa:timo-jyrinki/ppa

All credits to Timo Jyrinki.

This solved the problem for me, in a gnome-shell environment (which uses gdm).

share|improve this answer
    
also seems to solve it –  Jean-Michel Garcia May 4 at 18:29

Screen tearing can also be caused by xfce compositing or window manager with compositing that doesn't suppport vblank sync! To fix the issue i used compton, which completely stops the tearing, it's also quite easy to configure, i followed this guide and i haven't had any problems.

share|improve this answer

I stumbled across this query whilst looking for solutions to the same problem with my AMD hybrid card (Radeon HD 8650G) and thought I'd drop an answer for others arriving here for the same reason.. I've managed to get all the proprietary drivers downloaded from AMD to run on Trusty, but the tearing has always remained present. The only version that has worked for me is to install the experimental drivers which have a 'tear free' page which works. The version is fglrx-14.20 which is packaged as

linux-amd-catalyst-14.6-beta-v1.0-jul11.zip

The latest stable release of fglrx - 14.301.1001 does not have the 'tear free' page and does not stop the tearing. A downgrade to 14.20 brought back the desired behaviour in both video playback and games. Hope this helps.

share|improve this answer

For those who are unable to solve the issue by both package update from Timo Jyrinki and downgrading the Catalyst Control Center, try this method:

  1. Download Catalyst 14.9, packaged as

    amd-catalyst-14-9-linux-x86-x86-64.zip

  2. Download Catalyst 14.6 Beta, packaged as

    linux-amd-catalyst-14.6-beta-v1.0-jul11.zip

  3. Install Catalyst 14.6 Beta First using method given here.

  4. After Successful installation, reboot. Then open Catalyst Control Center and set Tear Free Desktop to ON.
  5. Reboot. Then purge the Catalyst by:

    sudo apt-get purge fglrx*
    
  6. WITHOUT Rebooting, still in terminal, install Catalyst 14.9 using same method as Catalyst 14.6 was installed.

  7. After Successful installation, reboot. Then set VSync to Always ON.

Now you have your latest Catalyst Control Center with Tear Free Desktop enabled. This method worked on Ubuntu 14.04 and Linux Mint 17

share|improve this answer

protected by Community May 5 at 19:41

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.