Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I upgraded from 12.04 to 14.04 and the performance is extremely sluggish; windows open and close in slow motion. Presumably my graphics hardware has not been recognized by the system. I think that I need advice about how to figure out what to do. Maybe I should install some graphics software or maybe I should disable something in Unity, but I don't know where to start.

My 'uname -a' command says this:

Linux home0 3.13.0-24-generic #46-Ubuntu SMP Thu Apr 10 19:08:14 UTC 2014 i686 i686 i686 GNU/Linux

A command 'sudo lshw' gives lots of information and I will try to extract what may be most relevant:

home0
description: Desktop Computer
product: TPS01 ()
vendor: FOXCONN
version: 1.0
serial: To Be Filled By O.E.M.
width: 32 bits
capabilities: smbios-2.6 dmi-2.6 smp-1.4 smp
configuration: boot=normal chassis=desktop cpus=2 uuid=6013CF95-1E02-E531-FD14-D027881B608D

*-core
[...]
*-firmware
description: BIOS
vendor: American Megatrends Inc.
physical id: 0
version: 080015
date: 06/07/2010
size: 64KiB
capacity: 960KiB
capabilities: isa pci pnp apm upgrade shadowing cdboot bootselect socketedrom edd int5printscreen int9keyboard int14serial int17printer int10video acpi usb ls120boot zipboot biosbootspecification

*-cpu:0
description: CPU
product: Intel(R) Atom(TM) CPU D525   @ 1.80GHz
vendor: Intel Corp.
physical id: 4
bus info: cpu@0
version: 6.12.10
serial: 0001-06CA-0000-0000-0000-0000
slot: CPU 1
size: 1800MHz
capacity: 1900MHz
width: 64 bits
clock: 200MHz
capabilities: x86-64 boot fpu fpu_exception wp vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx constant_tsc arch_perfmon pebs bts aperfmperf pni dtes64 monitor ds_cpl tm2 ssse3 cx16 xtpr pdcm movbe lahf_lm dtherm
configuration: cores=2 enabledcores=2 id=3 threads=4
[...]

*-pci
description: Host bridge
product: Atom Processor D4xx/D5xx/N4xx/N5xx DMI Bridge
vendor: Intel Corporation
physical id: 100
bus info: pci@0000:00:00.0
version: 02
width: 32 bits
clock: 33MHz
configuration: driver=agpgart-intel
resources: irq:0

*-display
description: VGA compatible controller
product: Atom Processor D4xx/D5xx/N4xx/N5xx Integrated Graphics Controller
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
version: 02
width: 32 bits
clock: 33MHz
capabilities: msi pm vga_controller bus_master cap_list rom
configuration: driver=i915 latency=0
resources: irq:44 memory:fea80000-feafffff ioport:dc00(size=8) memory:d0000000-dfffffff memory:fe900000-fe9fffff

Addendum: Here is the output from a unity_support_test command.

/usr/lib/nux/unity_support_test -p

OpenGL vendor string:   Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) IGD x86/MMX/SSE2
OpenGL version string:  1.4 Mesa 10.1.0

Not software rendered:    yes
Not blacklisted:          yes
GLX fbconfig:             yes
GLX texture from pixmap:  yes
GL npot or rect textures: yes
GL vertex program:        yes
GL fragment program:      yes
GL vertex buffer object:  yes
GL framebuffer object:    yes
GL version is 1.4+:       yes

Unity 3D supported:       yes

And here is the output from lspci:

lspci -k | grep -A3 VGA

00:02.0 VGA compatible controller: Intel Corporation Atom Processor D4xx/D5xx/N4xx/N5xx Integrated Graphics Controller (rev 02)
    Subsystem: Foxconn International, Inc. Device 0d55
    Kernel driver in use: i915
00:1b.0 Audio device: Intel Corporation NM10/ICH7 Family High Definition Audio Controller (rev 02)

Further addendum: I use this desktop for email, editing, web browsing. I don't care for gaming or for videos and I'll be happy to turn off whatever graphics treatment is associated with this extraordinarily slow behavior. It is not "normal slow" for old hardware; the hardware is i686 from 2010.

Let me clarify "slow". The expected behavior (my experience with 12.04) if I open an Xterm or a browser window is that I see some visual trickery whereby the new window smoothly acquires its size or its color. Under 14.04 the smoothness is all gone; the new window acquires its final state in a jagged manner changing its size or shape maybe once or twice per second over a few seconds. A youtube movie (displayed on Firefox) has a refresh rate of maybe 2 or 3 Hertz. If I type text into the Dash then the characters appear at a rate of maybe 1 per second.

In some similar conversations and questions from back in 2010-2011 I see references to issues with compiz, but I don't know what to do with that information. My System Monitor shows that the CPU usage of compiz shoots up to 48% or so whenever a window is opened; so it is taking essentially all of one CPU on my 2-CPU system. When I drag a window around it is a jagged and lagged motion and compiz usage goes up to 60% or more.

Perhaps it is relevant that my system has another problem as well: libudev.so.0 is not found (as is noticed when Chrome does not start). I really don't know if this may have anything to do with the graphics performance.

By the way, thank you to mikewhatever for editing this post to format the various system outputs as they were meant to be formatted; I had not recognized how to achieve that.

share|improve this question
    
The output you posted shows netbook hardware with an onboard Intel GPU, correct driver loaded, all recognised. Perhaps Unity's GPU demending effects are too much for it. Xubuntu or Lubuntu are usually recommended for slowish machines. –  mikewhatever Apr 19 at 12:34
    
Thank you, maybe I should use Lubuntu. However, Ubuntu 12.04 worked fine for me on this hardware. I notice that on start-up in 14.04 there is an error message that I haven't been able to capture, but it concerns gtk. –  user3054508 Apr 19 at 13:03
    
I am facing similar issue. When i open System monitor i see the cpu usage constant at 100%, compiz is the process that takes so much. My Hard ware - A8V-MX VIA K8M800 motherboard and AMD Athlon 3000 64 bit processor. –  newforubuntulinux Apr 20 at 4:23
    
I found advice from user stinkeye on ubuntuforums.org on 2013-05-01 to run the gnome-classic desktop using the metacity window manager. Do 'sudo apt-get install gnome-panel' and then choose gnome (metacity) at the login screen. I've done that and it seems to have solved the problem. Finding this took more effort than I could appreciate. Stinkeye's post: ubuntuforums.org/showthread.php?t=2140745 –  user3054508 Apr 20 at 8:19
    
Kaspin, User3...somenumbers, If you seek a desktop like unity but lighter and faster, there's always the 2d version - no need to install anything, have you tried that? –  Kurja Apr 24 at 17:00

4 Answers 4

The root of the problem described above is probably a lightdm bug:

https://bugs.launchpad.net/ubuntu/+source/unity-greeter/+bug/1292467.

I had this problem on an Atom Mini-ITX motherboard with Intel NM10 graphics which includes an internal LVDS display port. The Boot with "video=LVDS-1:d" workaround solved it for me. Instructions for making the boot option permanent are at How do I add a kernel boot parameter?.

The post by Andy Whitcroft on 2014-04-17 indicates that a fix has been released but it apparently hasn't made it into the updates repository at the time of this writing.

share|improve this answer
2  
This worked for my Lenovo X1 Carbon. Thanks! –  michuk May 18 at 11:47
    
Booting with "video=LVDS-1:d" workaround worked for me too. Would recommend this for anybody affected by this bug. –  Avian00 Jun 3 at 9:33

I had the same sluggish performance until following the advice in: https://sites.google.com/site/easylinuxtipsproject/first But I think the clincher, as mentioned in the above website and as stated by user3054508, is to change the display to gnome(matacity). It would be nice if a simpler version of the unity desktop could be provided in the future, without the fade-outs etc., so that those of us with old graphics cards are catered for. Kaspin

share|improve this answer
    
12.04 is still supported and includes the unity 2d desktop –  Elder Geek Oct 13 at 13:50

i faced the same problem. ubuntu was death slow after dist upgrade.

changing to gnome metacity was not an option for me.

what helped in my case:

sudo apt-add-repository ppa:xorg-edgers/ppa
sudo apt-get update
sudo apt-get install nvidia-current nvidia-settings

go to 'additional drivers' and choose any other driver than the selected default one. (was 'nouveau xorg server..' i believe.

(i have a nvidia nvs 310 graphic card and a high res dell display link display)

share|improve this answer
4  
The guy has an Intel card. –  michuk May 18 at 11:39

FIX:


If you have an Nvidia graphics card, then take user1429166's advice.

  1. Run the terminal commands and update your Nvidia drivers.
  2. Use the default 'additional drivers' software on Ubuntu to choose a new driver.

I was unsure of which version was Nvidia's current driver release (which i think is presently a beta release, so you probably want to avoid it.)

**I selected the one that wasn't a 'legacy' driver, and that was 'proprietary' software.

Edit:


It seems like an Intel card could always benefit from some driver installations, as well. Check the 'additional drivers' software and see if you are currently using the default 'X.org-Nouveau' driver.

share|improve this answer

protected by Community Jun 27 at 18:53

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.