Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Ubuntu 13.10, since glib 2.32 failed to compile some newer applications I compiled and installed glib 2.38 and its dependencies d-bus-1.8.0. When I booted in the morning I noticed that nm-applet was missing from indicator session area. At first I thought it was acting up of network manager daemon and I run:

sudo service network-manager restart

Icon appeared on awn indicator session area but doesn't show active device and connections list.

Then I run:

sudo nm-applet

wireless icon appeared in A notification area (systray) in place of awn indicator session area

And I get following messages in terminal:

 sudo nm-applet 
 ** Message: applet now removed from the notification area
 ** Message: using fallback from indicator to GtkStatusIcon

 ** (nm-applet:16151): WARNING **: Failed to register as an agent: (32) Session not found
 ** Message: applet now embedded in the notification area

Would anybody tell me how to fix it?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

I found a workaround that worked. D-bus-1.8.0 creates compatibily issue and needs new packages to get installed.

D-Bus Python-1.2.0
Py2cairo-1.10.0
PyCairo-1.10.0
PyGObject-2.28.6
PyGObject-3.12.1
PyGTK-2.24.0
PyXDG-0.25

But I didn't install them.

I found the workaround here:

https://bbs.archlinux.org/viewtopic.php?id=143985

sudo gedit /etc/dbus-1/system.d/org.freedesktop.NetworkManager.conf

I replaced all instances of deny with allow and saved.

I restarted session and it worked.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.