Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So yesterday I went ahead and bought the Samsung NP915S3G (ATIV Book 9 Lite) and installed Tahr in hope that everything would go smoothly. For the most part it; everything necessary seems to work off the bat. Unfortunately when I restart it, nothing boots. I erased Windows so that's obviously not an option, but the computer seems pretty dead certain that there's nothing there to boot. I think this might have a lot to do with UEFI which is a field I have next to no experience with. There also seems to be a fat32 partition that consistently reappears when I delete it.

Any help is much appreciated, thanks.The error displayed when trying to boot.

share|improve this question

marked as duplicate by bain, Alaa Ali, Eliah Kagan, Warren Hill, waltinator Aug 8 at 18:41

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
reboot from installation USB or DVD and run Boot Repair. –  the_Seppi Apr 19 at 11:14
    
You've probably got an EFI that's buggily refusing to boot anything but the Windows boot loader. Boot Repair can fix this, although without more information, I can't be certain that's a suitable response. You might try running it anyhow, or using the Boot Info Script to generate a file called RESULTS.txt. Post that file to a pastebin site and post the URL to the document here for further analysis. –  Rod Smith Apr 19 at 16:32
    
Unfortunately Boot Repair Disk doesn't seem to have any effect. Here's the BootInfo summary produced by it. paste.ubuntu.com/7298587 –  Ross Apr 21 at 13:11

2 Answers 2

Thats it working now guys, thanks for the help. I simply retried Boot Repair and ensured that "Separate /boot/efi partition" was ticked in the advanced options. This link was of great help.

https://help.ubuntu.com/community/UEFI#Identifying_if_the_computer_boots_the_Ubuntu_DVD_in_EFI_mode

Is there a way to mark this as solved like things were in the forums? Or any other etiquette to follow?

share|improve this answer

Your Samsung PC might be affected by the UEFI problem that Matthew Garrett mentions in his blog:

"The problem with Samsung laptops bricking themselves turned out to be down to the UEFI variable store becoming more than 50% full [...]" : http://mjg59.dreamwidth.org/23554.html

But there is a way to disable UEFI and use the legacy boot, which might solve your problem (Source):

  1. (Since you erased Windows 8, I won't cover the steps required with a Windows 8 installation)
  2. Boot your PC and press the bios key (in your case F2) repeatedly
  3. If a startup menu is shown select BIOS setup
  4. Locate the Boot options entry (Depending on your machine it may either be under System configuration or Security tab) and open it
  5. In the Boot options menu, enable Legacy Support
  6. (Optional) Change the Legacy boot order at the end of the page
  7. Save the changes and reboot
share|improve this answer
    
No, the computer is not bricked. It's much more likely another problem. –  Rod Smith Apr 19 at 16:29
    
I've found a post (ubuntuforums.org/showthread.php?t=2192346) with a similar problem. The asker has tried installing Ubuntu with secure boot disabled. Maybe it works after disabling secure boot or following any other steps in the mentioned post.. –  Cronoxyd Apr 20 at 13:50

Not the answer you're looking for? Browse other questions tagged or ask your own question.