Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I know that in Ubuntu 14.04 there exists nvidia-prime for Nvidia Optimus, but I don't like it and neither am I able to get it work. After upgrading from Ubuntu 12.04 everything crashed, and I made a clean install of Ubuntu 14.04 and Bumblebee, but now I have new troubles. After running optirun glxgears I get the following error:

**[ 4703.996785] [ERROR]Cannot access secondary GPU, secondary X is not active.**
**[ 4703.996910] [ERROR]Aborting because fallback start is disabled.**

Please help.

share|improve this question
    
CHeck this thread askubuntu.com/questions/452556/… – Ubuntuser May 1 '14 at 9:21

From: https://wiki.debian.org/Bumblebee#Common_issues

I had to edit the file '/etc/bumblebee/bumblebee.conf' and set the driver manually :

Driver=nvidia

You should have a corresponding [driver-nvidia] section in your file with the current version of your nvidia driver :

[driver-nvidia]
# KernelDriver=nvidia-current
KernelDriver=nvidia-331
# LibraryPath=/usr/lib/nvidia-current:/usr/lib32/nvidia-current
LibraryPath=/usr/lib/nvidia-331:/usr/lib32/nvidia-331
# XorgModulePath=/usr/lib/nvidia-current/xorg,/usr/lib/xorg/modules
XorgModulePath=/usr/lib/nvidia-331/xorg,/usr/lib/xorg/modules

then restart the bumblebee daemon :

sudo service bumblebeed restart 
share|improve this answer
    
You'll also want to make sure that the number in LibraryPath and XorgModulePath match the version of the nvidia driver you installed, because a default install, it's /usr/lib/nvidia-current .. but for stability you may have installed e.g. fixed version 367 instead of latest nvidia-current. – vorburger Jun 17 at 12:43

I believe that you need to set up a virtual server for your image output. I am not sure on 14.04, but I know this works for me on upgrading to 13.10 from 12.04. It is not specific to 14.04, but if you are stumped, this answer should provide some guidance:

External Monitor display on Thinkpad W520 with 12.04

Here is a quick summary of the answer on that link:

1) Install latest intel drivers, hope that intel-virtual-output, which is the integrated version of screenclone. If it's not packaged, compile that stuff from source.
2) In your xorg.conf.nvidia ensure the option preventing external screens is disabled.
3) Xrandr as usual :)
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.