Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I use a docking station with 2 external monitors and keep my laptop lid closed when docked.

In Gnome's power settings, I have set "Do nothing" when laptop lid is closed and this works fine (after adding the option manually through gconf-editor). However, when the screens are set to go to standby, they actually just blank, rather than changing their DPMS mode. This wastes electricity.

If the laptop lid is open, the monitors go to standby as expected. Things also work correctly when not logged in (in GDM) so I think it must have something to do with Gnome.

Any pointers?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Same problem here, VGA output to external monitor. Got it to work with

xset dpms 0 0 600

that's telling the monitor don't standby or suspend, but power off after 10 minutes (600 seconds)

I added the entry to System > Preferences > Startup Applications

share|improve this answer
    
followed some advice here: ubuntuforums.org/showthread.php?t=1202665 –  trts Jun 21 '11 at 2:41
    
Excellent, thank you, this works perfectly! –  gdi2k Jun 21 '11 at 6:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.