Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed MariaDb as its supported by Ubuntu community , mentioned in release note of latest LTS.

After that I tried to install Mariadb-client , that too installed successfully, after that its good to have GUI tool So decided to install MySql-workbench from both Ubuntu-SOftware-Center and via Terminal but it prompted errors mentioned below-

Error via Ubuntu-Software-Center-

 This error could be caused by required additional software packages which are missing or not installable. Furthermore there could be a conflict between software packages which are not allowed to be installed at the same time.
 mysql-workbench: Depends: libgcc1 (>= 1:4.1.1) but 1:4.9-20140406-0ubuntu1 is to be installed
             Depends: libgtkmm-2.4-1c2a (>= 1:2.24.0) but 1:2.24.4-1ubuntu1 is to be installed
             Depends: libpcrecpp0 (>= 7.7) but 1:8.31-2ubuntu2 is to be installed
             Depends: python:any (>= 2.7.1-0ubuntu2) but it is a virtual package
             Depends: mysql-workbench-data (= 6.0.8+dfsg-2) but 6.0.8+dfsg-2 is to be installed.

Error via Terminal-

 The following packages have unmet dependencies:
    mysql-workbench : Depends: mysql-client
    E: Unable to correct problems, you have held broken packages.

This one has become confirmed bug on launchpad as mentioned here.

On the official website of My-sql , the versions of workbench are only available till saucy (13.10) , So how can I install it.

UPDATE 1

Added the following lines in /etc/apt/sources.list

# MariaDB 10.0 repository list - created 2014-04-19 11:47 UTC
# http://mariadb.org/mariadb/repositories/
deb http://mirror.mephi.ru/mariadb/repo/10.0/ubuntu trusty main
deb-src http://mirror.mephi.ru/mariadb/repo/10.0/ubuntu trusty main

No change , still same issue. There is some problems between trusty and version 10.1.10 of Mariadb . So tried

sudo apt-get install libmysqlclient18=10.1.10-mariadb1~trusty mysql-common=10.1.10-mariadb1~trusty

And its output is -

E: Version '10.1.10-mariadb1~trusty' for 'libmysqlclient18' was not found
E: Version '10.1.10-mariadb1~trusty' for 'mysql-common' was not found

So the thing is simple it could not find it . though its there on the official website.

UPDATE 2

Removed MariaDB 10.1.10 , but the problem is still same with MariaDB 5.5.37.

share|improve this question
    
I think Mysql is in conflict with MariaDB –  karim Apr 19 at 8:29
1  
Here's a link to the already reported bug causing this. It is already fixed and scheduled for 6.1.7 bugs.mysql.com/bug.php?id=72729 –  elbaloo Jun 26 at 2:12

5 Answers 5

It's a bug and should be fix but it's a temporary solution:

  1. Unpack mysql-workbench-community-6.1.4-1ubu1310-amd64.deb in a folder.
  2. Change the file "DEBIAN/control", replace "mysql-client" to "mysql-client-5.6".
  3. Go to the terminal and make a new ".deb":

    dpkg -b mysql-workbench-community-6.1.4-1ubu1310-amd64/

Done! Now you can install from the new deb file.

share|improve this answer

I got around it by using the latest community version and removing mysql-client from the depends

Assuming mariadb is already installed

Download mysql workbench from http://dev.mysql.com/downloads/tools/workbench/ (version for 13.10 on 14.04 is fine)

From the directory the file is downloaded run:

sudo apt-get remove mysql-workbench mysql-workbench-data

dpkg-deb -x mysql-workbench-community-6.*.deb tmp_mysql-workbench
dpkg-deb --control mysql-workbench-community-6.*.deb tmp_mysql-workbench/DEBIAN
sed -i -e 's/mysql-client, //' tmp_mysql-workbench/DEBIAN/control
dpkg -b tmp_mysql-workbench mysql-workbench-community_patched.deb

sudo dpkg -i mysql-workbench-community_patched.deb
share|improve this answer
    
Great! just remove the trailing comma and space on the regex (4th line). In my case I replaced it with 'mysql-client-5.6' –  mppfiles Jun 18 at 2:12
    
Worked for 6.1.6 workbench and x64 ubuntu 14.04. Thnx! –  akikara Jun 23 at 14:04

I downloaded .deb from the official site (13.10), and I haven't got problem.

But I have mysql-server, not mariadb

share|improve this answer
    
yeah first of all am talking about 14.04 thats not available on official site for .deb file , secondly I have used that with ubuntu 13.10 too and it was working fine , third thing I want to know is there any work arround for this. Last thing gain some repo because this is not an answer just cant be considered a answer in any manner , you can comment it after gaining some. –  Sushantp606 Apr 19 at 10:09
1  
I use Ubuntu 14.04 to. I think you should use mysql-server raither than mariadb –  Nymeria Apr 19 at 10:37
1  
this will be my last option .. I will try to fix it, and wait for an answer till then. –  Sushantp606 Apr 19 at 11:09

I have had the 6.2.3-1ubu1404 version which did not contain "mysql-server" string at all. However because of unmet dependencies, I couldn't have installed.

Somehow, I tried to install the requirements manuall by

# sudo apt-get install libgtkmm-2.4-1c2a libtinyxml2.6.2 libzip2 python-paramiko libproj0 proj-data

I worked.

My actual error was this one:

$ sudo dpkg -i mysql-workbench-community-6.2.3-1ubu1404-amd64.deb 
Selecting previously unselected package mysql-workbench-community.
(Reading database ... 221745 files and directories currently installed.)
Preparing to unpack mysql-workbench-community-6.2.3-1ubu1404-amd64.deb ...
Unpacking mysql-workbench-community (6.2.3-1ubu1404) ...
dpkg: dependency problems prevent configuration of mysql-workbench-community:
 mysql-workbench-community depends on libgtkmm-2.4-1c2a (>= 1:2.24.0); however:
  Package libgtkmm-2.4-1c2a is not installed.
 mysql-workbench-community depends on libtinyxml2.6.2; however:
  Package libtinyxml2.6.2 is not installed.
 mysql-workbench-community depends on libzip2 (>= 0.10); however:
  Package libzip2 is not installed.
 mysql-workbench-community depends on python-paramiko; however:
  Package python-paramiko is not installed.
 mysql-workbench-community depends on libproj0; however:
  Package libproj0 is not installed.

dpkg: error processing package mysql-workbench-community (--install):
 dependency problems - leaving unconfigured
Processing triggers for gnome-menus (3.10.1-0ubuntu2) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu1) ...
Processing triggers for mime-support (3.54ubuntu1) ...
Processing triggers for menu (2.1.46ubuntu1) ...
Processing triggers for shared-mime-info (1.2-0ubuntu3) ...
Processing triggers for hicolor-icon-theme (0.13-1) ...
Errors were encountered while processing:
 mysql-workbench-community
dincer@dincerExp:~/Downloads$ sudo dpkg -i mysql-workbench-community-6.2.3-1ubu1404-amd64.deb 
(Reading database ... 223036 files and directories currently installed.)
Preparing to unpack mysql-workbench-community-6.2.3-1ubu1404-amd64.deb ...
Unpacking mysql-workbench-community (6.2.3-1ubu1404) over (6.2.3-1ubu1404) ...
Setting up mysql-workbench-community (6.2.3-1ubu1404) ...
Processing triggers for gnome-menus (3.10.1-0ubuntu2) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu1) ...
Processing triggers for mime-support (3.54ubuntu1) ...
Processing triggers for menu (2.1.46ubuntu1) ...
Processing triggers for shared-mime-info (1.2-0ubuntu3) ...
Processing triggers for hicolor-icon-theme (0.13-1) ...
share|improve this answer
    
m really very sorry but i dont have ubuntu installed at the moment .. So i ll try it after sometime time and then let u know .. –  Sushantp606 Oct 15 at 17:14
1  
just try same on debian which might even work. They are all deb repositories. I doubt the version numbers may match. But just try and let us know what happened. –  Dincer Oct 22 at 8:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.