Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I guess, there are plenty of duplicates of this question, but I didn't find any to be helpful in my particular problem.

My story is as follows: I was running Xubuntu 12.04 on a Thinkpad X40 which has an Intel 855GM graphics chip. On 12.04 suspend worked flawless. Yesterday I upgraded to 14.04 and this broke suspend. The problem is like this: I close the lid, the laptop goes to sleep. After some time I open the lid, the screen goes on and if I'm fast I can even start typing in the password. However some seconds later the screen switches off again, though I can hear that the system continues working. I can still switch to any TTY, only X has no graphical output. If I kill X from TTY, it starts again, I can login and then the system works as expected. In /var/log/Xorg.0.log I see following lines:

(II) AIGLX: Suspending AIGLX clients for VT switch
(II) AIGLX: Resuming AIGLX clients after VT switch
(II) AIGLX: Suspending AIGLX clients for VT switch

which exactly fits to my observations: On lid close the screen goes off, on opening the lid it goes on and then after some seconds off again.

Any thoughts on how to prevent X from switching off the screen after waking up?

Thanks for any input.

Bug reported: https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1310038

As somebody pointed out in an answer that seems deleted now, a workaround is to switch off light locker.

share|improve this question

2 Answers 2

up vote 4 down vote accepted

Here are a few options to avoid or recover from the issue.

Temporary fix

In the main bug ticket there's now a fix which involves adding a PPA:

  1. Add the Xubuntu Developers PPA to get the new packages: sudo add-apt-repository ppa:xubuntu-dev/ppa

  2. Update package information and update the two crucial packages:

    sudo apt-get update && sudo apt-get install xfce4-power-manager light-locker-settings

    xfce4-power-manager-data will get upgraded at the same time

  3. Restart your machine.

To remove the upgrades and return your machine to it's state prior to testing

sudo ppa-purge ppa:xubuntu-dev/ppa

Temporary workaround

The easiest way to work around this bug is to disable lock on suspend in the light locker settings. Of course, this means that your machine will resume from suspend without a password.

Quick fix

If you end up in this situation you can get back to a working state (note that you'll lose your current session and a new one will be started) by:

  1. Switch to a virtual terminal: CtrlAltF1
  2. Restart lightdm: sudo service lightdm restart
share|improve this answer
1  
Yep, I'm also following this bug already. :) Thanks for writing everything up though! –  Photon May 24 at 7:07
    
this did nothing for me personally. –  Joshua Robison Oct 28 at 0:15

Go to settings, light locker settings, and ENABLE the "lock on suspend" button, that works for me, and the system ask for my password to log in, without problems. I prove this with and without ac energy

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.