Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The day was going fine until I got a notification suggesting that I upgrade to Ubuntu 11.04 and I thought, "sure why not?"

The first problem was that I didn't like the new desktop, I wanted my old top panel back and the dock removed. So I went into the compiz settings and thinking that turning off unity might restore the old look I did that and now I have no panels or dock. This cut me off from any way I could think of to fix the problem(I can't quite remember but I must have closed the compiz window for some reason).

So I rebooted and logged back in with Ubuntu Classic, this was closer to what I wanted but I wanted my spinning cube back, so again I played with the compiz settings. This time I just checked the rotating cube, let the extra needed changes happen, and the frames around all my windows disappeared! Playing with the settings didn't bring them back so I did some googling but the only solution I found was to type "metacity --replace" into a terminal, but this only works as long as I keep the terminal open.

So I logged out and logged back in with Ubuntu Classic No Effects and came here. Basically, I want to turn compiz back on in regular Ubuntu and/or get my frames back in Classic Ubuntu, or just reset everything.

share|improve this question
    
Sorry Jarl i deleted my answer because after testing it in the exact way you mention it gave me the exact problem you have. I had to rest the whole desktop to have for example my windows titlebars again and have the ability to drag them around. There is something very bad with Compiz and 11.04 now. –  Luis Alvarado May 26 '11 at 12:46
add comment

3 Answers 3

To get your window titles and frames back, open your terminal and type this:

compiz-decorator --replace
share|improve this answer
add comment

I have same problems. I installed Compiz Fusion Icon from software centre. It installs on the panel, and there you can change the window manager permanetly to metaticity.

share|improve this answer
add comment

Run compizconfig, and under effects check windows decoration. This will essentially run compiz-decorator. When disabling unity this settings also gets disabled. When you enable unity this setting does not get enabled.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.