Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have been all over the internet about this problem, and everyone seems to have slightly different but unrelated errors to mine.

Rosegarden was working yesterday. Now, every time without fail, it will display the splash screen, some hint of a window, but then the area of the screen "freezes" and doesn't refresh (where you can "paint" over the area by dragging a window over it ;))

I tried:

sudo apt-get purge rosegarden
sudo apt-get autoremove
sudo apt-get install rosegarden

With a seemingly fresh install, things happened the exact same way.

Here's the terminal output:

Setting graphics system for Qt 4.5+ to: raster
Thorn - false
System Locale: en_US
Qt translations path: /usr/share/qt4/translations
Qt translations not loaded.
RG Translation: trying to load :locale/en_US
RG Translations loaded successfully.
Loaded application icon "rg-rwb-rose3-16x16"
Loaded application icon "rg-rwb-rose3-32x32"
Loaded application icon "rg-rwb-rose3-48x48"
Loaded application icon "rg-rwb-rose3-64x64"
Loaded application icon "rg-rwb-rose3-128x128"
NOTE: Found stylesheet at ":/rosegarden.qss", applying it
Not loading stylesheet per user request.  Caveat emptor.
QSettings::endGroup: No matching beginGroup()
AlsaDriver::AlsaDriver [begin]
Rosegarden 10.10 - AlsaDriver [ALSA library version 1.0.23, module version 1.0.23, kernel version 2.6.38-8-generic]
Cannot connect to server socket err = No such file or directory
Cannot connect to server socket
PluginFactory::instance(dssi): creating new DSSIPluginFactory
LADSPAPluginFactory::discoverPlugins - discovering plugins; path is [/home/chase/.dssi] [/usr/local/lib/dssi] [/usr/lib/dssi] 
Cannot connect to server socket err = No such file or directory
Cannot connect to server socket
jackdmp 1.9.7
Copyright 2001-2005 Paul Davis and others.
Copyright 2004-2010 Grame.
jackdmp comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
Cannot create thread 1 Operation not permitted
Cannot create thread 1 Operation not permitted
JACK server starting in realtime mode with priority 10
Cannot lock down memory area (Cannot allocate memory)
LADSPAPluginFactory::discoverPlugins - done
PluginFactory::instance(ladspa): creating new LADSPAPluginFactory
LADSPAPluginFactory::discoverPlugins - discovering plugins; path is [/home/chase/.ladspa] [/usr/local/lib/ladspa] [/usr/lib/ladspa] 
control device hw:0
control device hw:0
audio_reservation_init
Acquire audio card Audio0
creating alsa driver ... hw:0|hw:0|1024|2|44100|0|0|nomon|swmeter|-|32bit
control device hw:0
Using ALSA driver HDA-Intel running on card 0 - HDA Intel at 0x90700000 irq 46
configuring for 44100Hz, period = 1024 frames (23.2 ms), buffer = 2 periods
ALSA: final selected sample format for capture: 32bit integer little-endian
ALSA: use 2 periods for capture
ALSA: final selected sample format for playback: 32bit integer little-endian
ALSA: use 2 periods for playback
port created: Midi-Through:midi/playback_1
port created: Midi-Through:midi/capture_1
port created: USB-Uno-MIDI-Interface:midi/playback_1
port created: USB-Uno-MIDI-Interface:midi/capture_1
Cannot use real-time scheduling (RR/10)(1: Operation not permitted)
AcquireSelfRealTime error
LADSPAPluginFactory::discoverPlugins - done
Cannot lock down memory area (Cannot allocate memory)
Cannot use real-time scheduling (RR/5)(1: Operation not permitted)
AcquireRealTime error

JackDriver::initialiseAudio - JACK sample rate = 44100Hz, buffer size = 1024
JackDriver::initialiseAudio - creating disk thread
JackDriver::initialiseAudio - found 4 JACK physical outputs
JackDriver::initialiseAudio - connecting from "rosegarden:master out L" to "system:playback_1"
JackDriver::initialiseAudio - connecting from "rosegarden:master out R" to "system:playback_2"
JackDriver::initialiseAudio - found 4 JACK physical inputs
JackDriver::initialiseAudio - connecting from "system:capture_1" to "rosegarden:record in 1 L"
JackDriver::initialiseAudio - connecting from "system:capture_2" to "rosegarden:record in 1 R"
JackDriver::initialiseAudio - initialised JACK audio subsystem

  ALSA Client information:

    14,0 - (Midi Through, Midi Through Port-0)          (DUPLEX) [ctype 2, ptype 655362, cap 99]
    20,0 - (USB Uno MIDI Interface, USB Uno MIDI Interface MIDI 1)      (DUPLEX) [ctype 2, ptype 589826, cap 127]

AlsaDriver::setCurrentTimer((auto))
extractVersion: major = 1, minor = 0, subminor = 23, suffix = ""
AlsaDriver::versionIsAtLeast: is version 1.0.23 at least 1.0.14? yes
extractVersion: major = 2, minor = 6, subminor = 38, suffix = "generic"
AlsaDriver::versionIsAtLeast: is version 2.6.38-8-generic at least 2.6.20? yes
Using low-resolution system timer, sending a warning
    Current timer set to "system timer" with timer checks
    WARNING: using system timer with only 250Hz resolution!
AlsaDriver::initialiseMidi -  initialised MIDI subsystem

AlsaDriver::setCurrentTimer((auto))
extractVersion: major = 1, minor = 0, subminor = 23, suffix = ""
AlsaDriver::versionIsAtLeast: is version 1.0.23 at least 1.0.14? yes
extractVersion: major = 2, minor = 6, subminor = 38, suffix = "generic"
AlsaDriver::versionIsAtLeast: is version 2.6.38-8-generic at least 2.6.20? yes
Using low-resolution system timer, sending a warning
    Current timer set to "system timer" with timer checks
    WARNING: using system timer with only 250Hz resolution!
Composition::getTrackById(0) - WARNING - track id not found, this is probably a BUG src/base/Composition.cpp:1560
Available track ids are: 
AlsaDriver::addDevice(0,0)
CREATED OUTPUT PORT 3:out 1 - unnamed for device 0
Renamed 129:3 to General MIDI Device
AlsaDriver::addDevice(0,1)
AlsaDriver::setRecordDevice: device 1, action 1
WARNING: AlsaDriver::renameDevice: Cannot find device 1 in port map
port created: rosegarden:midi/capture_1
port created: rosegarden:midi/playback_2
port created: rosegarden:midi/playback_3
port created: rosegarden:midi/capture_3
port created: rosegarden:midi/playback_4
audio file manager emitting fake setValue(100)
RosegardenDocument::openDocument: Successfully opened document "/home/chase/.local/share/rosegarden/autoload/autoload.rg"
Object::connect: No such slot Rosegarden::AudioInstrumentParameterPanel::updateAllBoxes() in src/gui/editors/parameters/AudioInstrumentParameterPanel.cpp:81
Object::connect:  (receiver name: 'Audio Instrument Parameter Panel')
Object::connect: No such signal Rosegarden::CompositionView::contentsMoving (int, int) in src/gui/editors/segment/compositionview/SegmentMover.cpp:58
Object::disconnect: No such signal Rosegarden::CompositionView::contentsMoving (int, int) in src/gui/editors/segment/compositionview/SegmentMover.cpp:65
Object::connect: No such signal Rosegarden::CompositionView::contentsMoving (int, int) in src/gui/editors/segment/compositionview/SegmentPencil.cpp:61
Connecting my port 3 to 20:0 on reconnection
AlsaDriver::setPlausibleConnection: connection like "" requested for device 0
AlsaDriver::setPlausibleConnection: fuzzy match 20:0 USB Uno MIDI Interface MIDI 1 (duplex) available with fitness 1
AlsaDriver::setRecordDevice: device 1, action 0
AlsaDriver::setRecordDevice: port is 0:0
AlsaDriver::setRecordDevice: device 1, action 1
AlsaDriver::setRecordDevice: port is 20:0
AlsaDriver::setRecordDevice - successfully subscribed device 1 as record port
AlsaDriver::setPlausibleConnection: connection like "" requested for device 1
AlsaDriver::setPlausibleConnection: fuzzy match 20:0 USB Uno MIDI Interface MIDI 1 (duplex) available with fitness 1
DataBlockRepository::clear()
Studio::getMetronomeFromDevice: Having a look at device 1000
Studio::getMetronomeFromDevice: Having a look at device 10000
Studio::getMetronomeFromDevice: Having a look at device 0
Studio::getMetronomeFromDevice(0): device is a MIDI device
rosegarden: could not connect to socket
rosegarden: No such file or directory
Rosegarden: WARNING: No accurate sequencer timer available (and kernel is new enough for RTC addendum)
MAIN WINDOW DISPLAY WARNING:  type 2 text<h3>System timer resolution is too low!</h3>
Rosegarden: WARNING: No accurate sequencer timer available (and kernel is new enough for RTC addendum)
SystemFont::loadSystemFont[Qt]: wanted family LilyPond-feta-rosegarden at size 12, got family LilyPond-feta-rosegarden (exactMatch 1)
SystemFont::loadSystemFont[Qt]: wanted family LilyPond-feta-nummer-rosegarden at size 12, got family LilyPond-feta-nummer-rosegarden (exactMatch 1)
SystemFont::loadSystemFont[Qt]: wanted family LilyPond-parmesan-rosegarden at size 12, got family LilyPond-parmesan-rosegarden (exactMatch 1)
SystemFont::loadSystemFont[Qt]: wanted family bitstream vera serif at size 12, got family DejaVu Serif (exactMatch 0)
SystemFont::loadSystemFont[Qt]: wanted family luxi serif at size 12, got family DejaVu Serif (exactMatch 0)
SystemFont::loadSystemFont[Qt]: wanted family times new roman at size 12, got family Liberation Serif (exactMatch 0)
SystemFont::loadSystemFont[Qt]: wanted family times at size 12, got family Nimbus Roman No9 L (exactMatch 0)
SystemFont::loadSystemFont[Qt]: wanted family fughetta at size 12, got family DejaVu Sans (exactMatch 0)
Warning: Unable to load any of the fonts in "fughetta"
SystemFont::loadSystemFont[Qt]: wanted family georgia at size 12, got family DejaVu Sans (exactMatch 0)
SystemFont::loadSystemFont[Qt]: wanted family inkpen2 at size 12, got family DejaVu Sans (exactMatch 0)
Comparing current version "10.10" with latest version "11.06"
MAIN WINDOW DISPLAY WARNING:  type 4 text<h3>Newer version available</h3>
SystemFont::loadSystemFont[Qt]: wanted family inkpen at size 12, got family DejaVu Sans (exactMatch 0)
Warning: Unable to load any of the fonts in "inkpen2,inkpen"
SystemFont::loadSystemFont[Qt]: wanted family inkpen2 text at size 12, got family DejaVu Sans (exactMatch 0)
SystemFont::loadSystemFont[Qt]: wanted family inkpen text at size 12, got family DejaVu Sans (exactMatch 0)
SystemFont::loadSystemFont[Qt]: wanted family comic sans ms at size 12, got family DejaVu Sans (exactMatch 0)
SystemFont::loadSystemFont[Qt]: wanted family maestro at size 12, got family DejaVu Sans (exactMatch 0)
Warning: Unable to load any of the fonts in "maestro"
SystemFont::loadSystemFont[Qt]: wanted family opus at size 12, got family DejaVu Sans (exactMatch 0)
Warning: Unable to load any of the fonts in "opus"
SystemFont::loadSystemFont[Qt]: wanted family opus text at size 12, got family DejaVu Sans (exactMatch 0)
SystemFont::loadSystemFont[Qt]: wanted family petrucci at size 12, got family DejaVu Sans (exactMatch 0)
Warning: Unable to load any of the fonts in "petrucci"
SystemFont::loadSystemFont[Qt]: wanted family sonata at size 12, got family DejaVu Sans (exactMatch 0)
Warning: Unable to load any of the fonts in "sonata"
SystemFont::loadSystemFont[Qt]: wanted family steinberg notation at size 12, got family DejaVu Sans (exactMatch 0)
Warning: Unable to load any of the fonts in "steinberg notation"
SystemFont::loadSystemFont[Qt]: wanted family xinfonia at size 12, got family DejaVu Sans (exactMatch 0)
Warning: Unable to load any of the fonts in "xinfonia"

  ALSA Client information:

    14,0 - (Midi Through, Midi Through Port-0)          (DUPLEX) [ctype 2, ptype 655362, cap 99]
    20,0 - (USB Uno MIDI Interface, USB Uno MIDI Interface MIDI 1)      (DUPLEX) [ctype 2, ptype 589826, cap 127]

And that's it. Rosegarden just hangs there. Every time. I don't know what could possibly create some sort of error that would persist across a fresh install. It also appears that it can't load any fonts for some reason....

share|improve this question
    
This question should instead be filed as a bug report, thanks! Instructions here. –  Jorge Castro Feb 3 '12 at 0:37
add comment

closed as off topic by Marco Ceppi Feb 3 '12 at 0:50

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer

As you stated in your question:

Deleting everything listed by

find ~ -name "*rosegarden*"

under home directory fixed the issue. Rosegarden creates some hidden directories and files that I suppose became corrupt.

In this case, I'll see what causes the condition and file a bug.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.