Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to run optirun on my Lenovo G580 with nVidia GeForce 610M on Ubuntu 14.04. Getting the following error

$ optirun glxgears
[   98.457967] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) intel(0): [drm] failed to set drm interface version: Permission denied [13].
[   98.458061] [ERROR]Aborting because fallback start is disabled.

My .conf file: http://paste.ubuntu.com/7278805/

Please help asap,thanks

EDIT: I also tried to run nvidia-settings to enable the nVidia gpu,but it does not work and gives a blank error/dialog box:

enter image description here

share|improve this question

closed as off-topic by bain, Eric Carvalho, Jorge Castro, nux, Sneetsher Jul 15 '14 at 4:08

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems specific to development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – bain, Eric Carvalho, Jorge Castro, nux, Sneetsher
If this question can be reworded to fit the rules in the help center, please edit the question.

1  
I also tried solutions given here and here in vain. – leftisright Apr 19 '14 at 18:13
1  
All other solutions on the internet seem to address concerns where the error is [XORG] (EE) NVIDIA(0).. – leftisright Apr 19 '14 at 18:37
    
Try using virtualgl instead of primus. – renatov May 1 '14 at 14:03
    
@renatov can you tell me a complete procedure to do that? I don't know what is virtualgl,complete noob here. – leftisright May 2 '14 at 14:39
    
I encountered this problem as well and I found this question before finding the correct answer. So for future reference. This is bug 580 of the bumblebee project and the fix is described here: github.com/Bumblebee-Project/Bumblebee/issues/580 – Arno van der Weijden Jan 2 '15 at 10:26

I recently found a crude solution to this: purging all nvidia* related files using:

    sudo apt-get purge nvidia*
    sudo apt-get purge bumblebee*
    sudo apt-get update

And then using "Additional Drivers" from Dash, I selected "Using Nvidia binary driver- version 331.38 from nvidia-331(proprietary,tested) and selected "Apply Changes" to confirm.

A short download later, I could run glxgears with 4 times the framerate I ever got with the Intel HD 3000.

Although this is not a solution to my problem, still it enables me to use my Nvidia GPU,so I think i'll use this for now till I get a satisfactory solution to bumblebee.

share|improve this answer

Try using nvidia-prime. Check this post and follow Louis Matthijssen instructions. I have a Dell Inspiron 14R 5421 with GeForce 730M on Ubuntu 14.04 and everything is working just fine. I played Dota 2 in maximum video settings, everything working like a charm.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.