Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm on trusty and I can't lock my computer by any means. When I press Super+L or use the Lock button in the panel, the behavior is the same: the screen turns black and if I move the mouse, my desktop pops up again, without ever locking.

I'm on Trusty x86 and I confirmed that if I create a new user account, I can lock the screen in that account. I checked the Lock settings in "Brightness & Lock" and everything is grayed out, as the following screen capture shows. How can I enable the usual system lock again?

enter image description here

share|improve this question
up vote 3 down vote accepted

Do you use Unity Tweak Tool? You might have this option enabled and not even know about it:

enter image description here

share|improve this answer
    
You're right. How did this get enabled in the first place? I re-enabled locking in UTT and now Ubuntu is locking smoothly again. Thanks. – ecc Apr 18 '14 at 21:19
    
If you have a separate home partition it might be because of old settings from previous versions. I'm not really sure. – Canha Apr 18 '14 at 21:25
    
I had the same problem, and could only fix it by installing this tool. The tool could not have caused my issue, but it fixed it. – Jeff Mar 4 at 3:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.