Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am on a fresh install of ubuntu TT 14.04, I installed the VLC-player. (tried via software center and console)

The problem is that when I try to run VLC the icon will appear in tray and dash, but no window opens up. Console says:

max@schleptop:~$ vlc
VLC media player 2.1.5 Rincewind (revision2.1.2+git20140414+r54518+18+11~ubuntu14.04.1)
[0x1fbd058] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.

What am I doing wrong? How do I get to see the interface?

gz

share|improve this question
    
I have the same problem. When i use open source graphic drivers, there is no problem. But when i use nvidia proprietary driver, vlc and some other apps work background but no interface. Even there is sound on background but no video. –  sefaustun Apr 23 at 10:42

4 Answers 4

I solved the problem by chancing screen settings. When i use 'super+s' short key, i noticed that i have dual screen and Vlc Player starts to work on the other screen. In the screen settings, i checked 'reflect screen' option. Now Vlc Player works normal.

share|improve this answer
    
Confirming that @sefaustun 's solution worked for me. My vlc, wine applications were not displayed to me earlier and also I had issues connecting an external monitor. –  Supreethks Aug 4 at 10:27

In Software Updater ==> Settings ==> Additional Drivers try to use another graphic card driver. I don't know why, but for me worked very well. Hope it will also work for you

Regards!

share|improve this answer

I believe this is a bug. However, this happens to me whenever I try to use a skin in VLC Media Player. I select the skin file in VLC Media Player's settings, save, restart VLC Media Player, and then VLC Media Player appears in the tray and in the dash, but after about half a second it disappears almost as if it closed itself.

share|improve this answer

I was following sefaustun's suggestion, when I found a second "unknown monitor" in my screen settings; all I had to do was to switch it off and vlc got back working as usual. (I'm using ubuntu 14.04, the basis is the same as lubuntu, so it should work fine in your case too)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.