Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Using Ubuntu 12.0.4 LTS and need to enable x11vnc access with admin and viewonly access based on which vnc password is supplied.

The x11vnc server gets started out of /etc/lightdm/start via:

/usr/bin/x11vnc -forever -rfbauth ~/.vnc/x11vnc.pass -o ~/.vnc/x11vnc.log -display :0

I can create the password file and set a full access password via

$ x11vnc -storepasswd 'test1pwd' ~/.vnc/x11vnc.pass
stored passwd in file: /home/rxclient/.vnc/x11vnc.pass

Using vncviewer from another system, the login works

$ vncviewer wks13
Connected to RFB server, using protocol version 3.8
Performing standard VNC authentication
Password: <test1pwd>
Authentication successful
Desktop name "wks13:0"

No matter what I've tried, I cannot get a second, viewonly passwd to work using the -rfbauth on the server.

The only thing that worked was to create a clear-text file with two passwords and changing the -rfbauth to -passwdfile.

With -rfbauth, the full access password works, the viewonly passwd results in a password check failed message.

Would appreciate instructions/clarification on how to set up x11vnc to use -rfbauth and two non-cleartext passwords, one for full access, one for viewonly.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.