Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In previous versions of Ubuntu, picking one of the default wallpapers meant that you saw it on the login screen as well.

I am now on a clean install of Ubuntu 14.04, the LightDM wallpaper appears to be set at /usr/share/backgrounds/warty-final-ubuntu.png. It is ignoring anything else.

I tried setting a wallpaper by right clicking the desktop and choosing one of the default set (e.g. the one corresponding to /usr/share/backgrounds/Forever_by_Shady_S.jpg). I then rebooted, but the LightDM wallpaper is still the default purple one.

I had a look at the log file at /var/log/lightdm/x-0-greeter.log :

[+0.10s] DEBUG: background.vala:483: Regenerating backgrounds [+0.10s]

DEBUG: background.vala:68: Making background

/usr/share/backgrounds/warty-final-ubuntu.png at 1920x1200,1440x900

The wiki page appears to be out of date as it is pointing to configuration file locations which no longer exist in 14.04.

I did manage to find some potential config files at /usr/share/lightdm/lightdm.conf.d/ but the files there don't contain any specific path locations, so I am not sure how to proceed.

I am aware of LightDM's pickiness - so this is about the default wallpapers that come with Ubuntu, all have read permissions globally and aren't encrypted or on separate drives.

enter image description here

share|improve this question
    
My experience is, that the wallpaper that you set appears when locking the screen with the new greeter. –  LiveWireBT Apr 22 at 14:26
    
Can you plese acctped an answer? –  Andrew May 12 at 2:24
    
It seems that the answer given by Bruno Pereira in [this post][1] still works. [1]: askubuntu.com/questions/64001/… –  Valezan May 31 at 15:46

5 Answers 5

How to Change the LightDM wallpaper

  1. Install Ubuntu Tweak

    First Install Ubuntu Tweak Click here to download the .deb and install it though Gdebi, Ubuntu Software Center, ect... Or You can install it though the terminal by these two/three commands:

    wget https://launchpad.net/ubuntu-tweak/0.8.x/0.8.7/+download/ubuntu-tweak_0.8.7-1%7Etrusty2_all.deb
    sudo dpkg -i ubuntu-tweak_0.8.7-1%7Etrusty2_all.deb
    

    OR

    sudo add-apt-repository ppa:tualatrix/ppa
    sudo apt-get update
    sudo apt-get install ubuntu-tweak-tool
    
  2. Open Ubuntu Tweak

    and follow the steps shown in the images below:

enter image description here

enter image description here

enter image description here

enter image description here

enter image description here

enter image description here

share|improve this answer

I had a similar situation like you, but solved in a real simple way. For me, I successfully changed the background of lightdm to some custom wallpaper after a clean install. Then today, I changed it to another wallpaper and it failed and showed the default purple one.

So, I checked the x-0-greeter.log and found out that it tried to load my wallpaper but failed because the greeter had no permission. Then I checked the permission of the wallpaper image, and for some reason the permission setting for 'Others' was set for 'None'. I changed it to 'Read-only' and then greeter can now successfully load the custom wallpaper.

Perhaps that might be the reason for your case too.

share|improve this answer
up vote 4 down vote accepted

In my case this solved the problem.

The org.gnome.settings-daemon.plugins.background setting had been disabled but I cannot determine why. Once I checked this checkbox in dconf-editor and changed my wallpaper, it was reflected on the login screen.

enter image description here

share|improve this answer
    
I had the same issue after upgrading to 14.04. This solved my problem! –  DisgruntledGoat May 13 at 20:54

I just solved this by copying my background image into the folder /usr/share/backgrounds (with a pkexec nautilus -- lazy me, or in a better way with sudo cp /path/to/image.jpg /usr/share/backgrounds). After that, I changed the background image from Unity in a regular way. You have to do this last change for any of the desktop manager you have on your system. Also, I think image has to be outside of the user's folder.

It worked for me.

share|improve this answer
    
Thanks jkt123 for correcting my grammar. Now I speak better English thanks to you. –  CiberSheep Apr 22 at 10:26
    
FYI askubuntu.com/questions/11760/… –  LiveWireBT Apr 22 at 14:36
    
Thanks livewirebt. I didn't know about that. Now I wil not forget, though. I guess is better to use sudo cp then –  CiberSheep Apr 22 at 20:33
    
Thank you terdon. –  CiberSheep May 13 at 10:19

I simply copied my wallpaper on top of /usr/share/backgrounds/warty-final-ubuntu.png and it worked without problems.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.