Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have my laptop monitor and my external monitor.

What I'm trying to do is have both monitors enabled, but the gnome-panel should be on my laptop monitor.

Also, when I open new windows (browser, application, anything..) this should be displayed on my laptop monitor.

I.e., the external monitor should only have windows I dragged directly to it.

How?

PS: Tryed enabling the option Make this the primary display for the X screen, but this option make new windows open on the external monitor, instead of the damn laptop monitor setted to be the PRIMARY DISPLAY, as the option says.

I can't get this settings correctly. Any help?

share|improve this question

2 Answers 2

If you are using Natty, or Compiz this is due to the place windows plug-in.

To change this install CCSM

apt-get install compizconfig-settings-manager

Then select the 'place windows' plugin, and there are a number of options for the 'multi-output mode' which you should be able to tailor for your needs.

share|improve this answer
    
Sorry; I'm not using compiz. And my ubuntu version is 10.10 –  Gabriel L. Oliveira May 26 '11 at 1:15

When it comes to gnome-panel, you can place it on a different monitor using:

gconftool-2 --set "/apps/panel/toplevels/top_panel_screen0/monitor" --type integer "1"

Feel free to adjust the monitor number appropriately.

share|improve this answer
    
This worked till I got my gnome-panel in the monitor I wanted. But every new window I opened, keeped opening on the external monitor. Do you know how to change this behaviour? –  Gabriel L. Oliveira May 26 '11 at 1:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.