Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I upgraded from 13.10 to 14.04 and now the nm-applet no longer shows in the system tray. I already tried purging and reinstalling the network-manager-gnome package but that didn't help. When I run nm-applet manually in the terminal I get the following output:

** (nm-applet:7419): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-gBrnqcTAVj: Connection refused

I tried multiple system trays: i3bar (my default), trayer and the xfce4-panel. Other tray apps work in all three of them (like dropbox). The network manager itself works, as it connects to known networks and outputs notifications. Does someone know how to fix this?

share|improve this question

marked as duplicate by bain, Eric Carvalho, Sneetsher, bodhi.zazen, waltinator Jun 21 at 1:09

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
I have the same issue, but the page linked in Guest's answer doesn't help. I use xfce4 in ubuntu 14.04 and did see the network manager applet icon in the notification area after first upgrading to 14.04, but a couple of days later it disappeared. I'm guessing it must be an update I applied after upgrading to 14.04. nm-applet and NetworkManager are both running, and if I edit /usr/share/applications/gnome-network-panel.desktop to say OnlyShowIn=GNOME;XFCE; then run gnome-control-center network I can connect to wireless networks, and the nm-applet bubbles pop –  Chris Moore Apr 21 at 19:22

6 Answers 6

It turns out that to see the nm-applet icon, you have to install package "xfce4-indicator-plugin" and add "Indicator Panel" to the panel.

That adds a whole bunch of icons that you probably don't want, and that ignore your theme choice. But at least you'll have the nm-applet icon again. For a while. The indicator-panel dies every few seconds for me, and when it does stay running long enough for me to try configuring it, the configuration panel doesn't work either.

Your mileage may vary - try the "Indicator Panel" and see if it works for you.

share|improve this answer
    
yes! and this also shows skype status again :-) –  sivann Jun 6 at 7:52
1  
The indicator panel is way too buggy. Whenever I switch desktop the indicator crashes... –  tutuca Sep 26 at 17:25

You could use the indicator plugin instead, but you may see frequent crashes. The crash is caused by the Applications Menus indicator. Add the indicator plugin and, before it crashes, right click on it, choose 'properties' and tick the 'hidden' checkbox next to the 'Application Menus (Global Menu)' indicator. Then restart the panel with 'xfce4-panel -r'

Instead, I fixed nm-applet by changing the 'Exec' line in /etc/xdg/autostart/nm-applet.desktop to 'dbus-launch nm-applet'

share|improve this answer
1  
I agree, changing nm-applet.desktop as in your second paragraph is what's worked for me, on multiple machines that I've been upgrading from 13.10 to 14.04, with xfce. Needs a reboot after first editing that file, and there's a few seconds delay each time after logging in before the indicator appears on the bar, but it works. –  Rob Hoare May 11 at 20:14
    
Changing nm-applet.desktop worked for me as well. One thing to add, I got tripped up for a while because I unknowingly had a ~/.config/autostart/nm-applet.desktop file which was overriding this. I removed that and everything worked fine. –  Josh Johnson Nov 7 at 1:52

I had the same problem, but i just kill 'indicator-application-service' and icons network, bluetooth and skype appear again. I use xfce on amd64.

share|improve this answer

I found the solution to this problem here: http://linuxg.net/how-to-fixrestore-the-missing-network-manager-from-the-unity-top-panel-on-ubuntu-13-04-raring-ringtail-and-ubuntu-12-10-quantal-quetzal/

Quoting their site: The fix for this issue is simple, first stop the network-manager service, like this:

$ sudo /etc/init.d/network-manager stop

Delete the /var/lib/NetworkManager/NetworkManager.state file:

$ sudo rm /var/lib/NetworkManager/NetworkManager.state

Turn back on the network-manager service:

$ sudo /etc/init.d/network-manager start
share|improve this answer

I have the same issue and came across this solution: http://www.webupd8.org/2014/04/fix-lubuntu-1404-network-manager.html

Hope this helps!

share|improve this answer
3  
Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Eric Carvalho Apr 18 at 20:17

I blatantly stole the answer from one of the comments to http://www.webupd8.org/2014/04/fix-lubuntu-1404-network-manager.html as Adz linked to and Eric Carvalho suggested be included in an actual answer. So, now we have the answer here in AskUbuntu. This is what I did.

Dimitrios Charalampidis
This fix does not work for everybody... if that's the case for you, too.. then try this: go to menu >Preferences > Default applications for LXSession, select the autostart tab and scroll to find Network. Uncheck it and recheck it, then go to your home folder and press ctrl+h to show hidden files and folders, go to .config/autostart, there you will find a Network.desktop file right click on it and select Leafpad, it is likely that under NotShowIn section it includes LXDE just delete it, save the file and exit, then log out and login again this will fix the issue.

For those that came looking for the actual answer on that website, here it is.

Lubuntu 14.04: fix 1

To fix the Network Manager not showing up on the panel issue, from the Lubuntu menu select Preferences > Default applications for LXSession, then click on the Autostart tab and under "Manual autostarted applications" type "nm-applet", then click the "+ Add" button on the left:

Now log out, log back in and you should see the Network Manager icon on the panel:

fix somewhat via lffl.org

Lubuntu 14.04 / Xubuntu 14.04: fix 2

If the above solution didn't work for you in Lubuntu 14.04 or if you're using Xubuntu 14.04 and you're having this issue, here's another solution. Basically, the solution below is for those who must run "nm-applet" as root to get it to show up in the pane - we'll be using dbus-launch to launch nm-applet at startup.

To get the Network Manager applet to work properly in either Lubuntu 14.04 or Xubuntu 14.04, run the following command: sudo sed -i 's/Exec=nm-applet/Exec=dbus-launch nm-applet/' /etc/xdg/autostart/nm-applet.desktop The command above replaces "nm-applet" with "dbus-launch nm-applet" in the nm-applet autostart desktop file.

UPDATED Ok, I also followed the advice from here: http://www.bauer-power.net/2014/05/permanent-fix-for-missing-network.html

What you need to do is edit /etc/xdg/autostart/nm-applet.desktop with your favorite text editor. I like nano, so I ran the following from the terminal: sudo nano /etc/xdg/autostart/nm-applet.desktop Go down to the Exec line and change the entry from nm-applet to dbus-launch nm-applet. Save the file and reboot!

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.