Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So I've got this killer PC I use for GPGPU programming. Hardware:

  • Intel i7-4770K (integrated intel HD4600)
  • 2x NVidia Geforce GTX780Ti

I want to use the GTX'es only for CUDA programming. It's a clean install of Ubuntu 14.04 at the moment, but having the same issues as I had with 13.10. No NVidia driver has been installed yet. My BIOS is configured to send output to integrated graphics.

The problem is that I do not have hardware rendering!

If I run "/usr/lib/nux/unity_support_test -p"

OpenGL vendor string:   VMware, Inc.
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.4, 256 bits)
OpenGL version string:  2.1 Mesa 10.1.0

Not software rendered:    no
Not blacklisted:          yes
GLX fbconfig:             yes
GLX texture from pixmap:  yes
GL npot or rect textures: yes
GL vertex program:        yes
GL fragment program:      yes
GL vertex buffer object:  yes
GL framebuffer object:    yes
GL version is 1.4+:       yes

Unity 3D supported:       no

For "lshw -c video" I get

  *-display UNCLAIMED     
       description: VGA compatible controller
       product: GK110B [GeForce GTX 780 Ti]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller cap_list
       configuration: latency=0
       resources: memory:da000000-daffffff memory:d0000000-d7ffffff memory:d8000000-d9ffffff ioport:e000(size=128) memory:db000000-db07ffff
  *-display UNCLAIMED
       description: VGA compatible controller
       product: GK110B [GeForce GTX 780 Ti]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller cap_list
       configuration: latency=0
       resources: memory:ca000000-caffffff memory:c0000000-c7ffffff memory:c8000000-c9ffffff ioport:d000(size=128) memory:cb000000-cb07ffff
  *-display
       description: VGA compatible controller
       product: Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 06
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:46 memory:db400000-db7fffff memory:b0000000-bfffffff ioport:f000(size=64)

Clean install, nothing special, I don't even think the two NVidia cards play any role as they are clearly not configured at the moment.

EDIT: This might be interesting, from Xorg.0.log

[   889.451] (II) intel(0): RandR 1.2 enabled, ignore the following RandR disabled message.
[   889.451] (==) intel(0): DPMS enabled
[   889.451] (WW) intel(0): [DRI2] Direct rendering is not supported when VGA arb is necessary for the device
[   889.451] (==) intel(0): hotplug detection: "enabled"
[   889.451] (--) RandR disabled
[   889.451] (II) Found 2 VGA devices: arbiter wrapping enabled
[   889.454] (II) SELinux: Disabled on system
[   889.455] (II) AIGLX: Screen 0 is not DRI2 capable
[   889.455] (EE) AIGLX: reverting to software rendering

EDIT2: So does this say "There are two VGA devices so I need VGA arbiter wrapping. Because I need VGA arbiter wrapping, direct rendering (DRI) is not possible. If DRI is not possible, unity is not possible". Any way of bypassing this? Surely this is fixable?

Any ideas?

share|improve this question

2 Answers 2

Short answer: Try installing Nvidia's driver using one of Ubuntu's own tools - look for additional drivers in the menu.

Explanation: When you have just installed Ubuntu, you may be using a driver that is under development and not feature-complete. I'm not sure about support for your particular video card, but it sounds very likely that only the chip manufacturer's (Nvidia) own driver can provide hardware acceleration for your use case.

share|improve this answer
    
It's not about the NVidia driver. I want DRI from the intel GPU. Thanks anyway. –  Ruben May 5 at 12:43

I had a surprising solution for this problem that worked for video and sound. User was not added to groups video and audio!

sudo usermod -a -G video your_username

sudo usermod -a -G audio your_username

hope this helps

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.