Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I try to start Rhythmbox its window remains only for few seconds then it disappears and I get "An internal Ubuntu error" message. Even if I try to open an MP3 file I see the same scenario.

Tried to reinstall it (twice :D)

Started from command line:

(rhythmbox:9164): Gtk-CRITICAL **: gtk_css_provider_load_from_path: assertion 'path != NULL' failed

(rhythmbox:9164): GLib-GObject-CRITICAL **: object SoupServer 0x2afc3e0 finalized while still in-construction

(rhythmbox:9164): GLib-GObject-CRITICAL **: Custom constructor for class SoupServer returned NULL (which is invalid). Please use GInitable instead.
Unable to open ~/.mtpz-data for reading, MTPZ disabled.Segmentation fault (core dumped)

UPDATE

Just found a bug report to launchpad: https://bugs.launchpad.net/ubuntu/+source/rhythmbox/+bug/1299245 , but the problem does not seem to be fixed

share|improve this question
    
Start it from command line and check if it throws an error. If so copy it into your question please. –  Rinzwind Apr 18 at 9:53
    
@Rinzwind I updated the question, as I see there is no "~/.mtpz-data" file or directory –  micnic Apr 18 at 9:59
    
@micnic - there is not "fix" because the OP in the bug report never supplies a stack-trace thus it become unreproducible. Try resetting rhythmbox as per here and if it works, you'll need to reimport/re-do all of your music/playlists/ratings again. askubuntu.com/questions/7979/… –  fossfreedom Apr 18 at 10:11
    
thank you @fossfreedom , I removed those folders and it worked , your comment should be an answer, post it as an answer and I'll accept it as the best one ;) –  micnic Apr 18 at 10:17

2 Answers 2

up vote 3 down vote accepted

Trouble-shooting

Trouble-shooting rhythmbox issues can be a bit of a trial and error.

These are the areas you should consider.

Cleaning up plugins settings

Sometimes a rogue plugin (internal or external) could be the cause of rhythmbox crashes.

Cleaning up the gsettings database for the various plugins can work:

gsettings reset-recursively org.gnome.rhythmbox.plugins

Cleaning up locally installed plugins

Occasionally, compilation issues occur if you install external plugins manually - removing these plugins and reinstalling will resolve this.

rm -rf ~/.local/share/rhythmbox/plugins

Cleaning up all rhythmbox settings

Occasionally, a corruption can occur in other rhythmbox settings. Using Dima's answer here will resolve this.

last resort

If the above does not work then the problem is likely to be due to corruption in the rhythmbox database and related files itself. Using Alvin's answer here will resolve this.

Note though - if you use the last resort method you'll need to reimport/re-do all of your music/playlists/ratings again.

share|improve this answer

Disable replay gain in plugins as it has issues with VBR tracks. I found on 12.04 it wasn't a issue but 14.04 started giving me problems with this. What I figured out it could be a gstreamer issue.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.