Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I install fresh Ubuntu 14. 04 server under ESXI 5.1.0.
During my installation I did not get any erorrs or strange things. My problem is when I boot machine at console screen I get messages like

[ 6.958104] intel_rapl: no valid rapl domains found in package 0 
[ 7.508153] intel_rapl: no valid rapl domains found in package 0
[ 8.058695] intel_rapl: no valid rapl domains found in package 0
[ 8.609932] intel_rapl: no valid rapl domains found in package 0
[ 9.163260] intel_rapl: no valid rapl domains found in package 0

After that messages I am able to log in and my to me Ubuntu works OK. I have internet connection I am able to call apt-get update and I am able to login over SSH.

Should I investigate these errors deeply before I continue build my server.
Do I need to react on these Messages or it is ok to run Ubuntu like this.

share|improve this question
The intel_rapl message was driving me crazy. The solution for me was to (sudo) edit /etc/modprobe.d/blacklist.conf and add blacklist intel_rapl. No more messages after reboot. – Zyphrax Nov 12 '14 at 6:18
odd... i got this on a fresh install under Parallels and the initial boot process doesn't get past seeing this message. – Michael Jun 30 at 19:41
up vote 24 down vote accepted

This was a change introduced in October 2013 to support Intel RAPL power capping driver in the Linux kernel. This message is non-obstructive, and when it appears it doesn't affect the performance or functionality of the system, since it's only a power management module.

If your virtualization software supports this driver (and the host supports advanced power features) then the message disappears.

You can check the source tree of the module to check what it does.

share|improve this answer

I know in virualbox you can enable PAE/NX which will solve "no valid rapl domains found in package" on Ubuntu 14.04 LTS. I don't know how about ESXI if it supports PAE/NX or not.

share|improve this answer
I'm on 14.04, with PAE/NX enabled, and still see the message. – cHao Jan 20 '15 at 6:32
I tried your solution to run Ubuntu 16.04 LTS and it worked like a charm. Thanks. – H.Josef May 15 at 17:54
I still see the message but it can boot into Ubuntu. – Student T May 30 at 1:01

protected by Seth Apr 24 '14 at 19:28

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.