Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I upgraded my Ubuntu GNOME 13.10 installation today by using: do-release-upgrade in the terminal.

When I came back it was on a tty (at least I think it was a tty)! Then as I couldn't go back to the desktop by using alt+F7 I rebooted. GNOME-shell came up, but couldn't move the mouse! I dropped back to alt+f2 and run: sudo apt-get update and sudo apt-get dist-upgrade. It downloaded a bunch of stuff and manually installed GNOME-shell again.

Now my installation is working fine, except I don't have the GNOME control panel, trying to install it shows me this:

~$ sudo apt-get install gnome-control-center
[sudo] password for : 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
gnome-control-center : Depends: gnome-control-center-data (< 1:3.7) but 1:3.10.1-0ubuntu1~saucy3 is to be installed
Recommends: gnome-control-center-shared-data but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
laptop:~$ sudo apt-get install -f‍‍‍
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
blt guile-1.8 guile-1.8-libs libamd2.2.0 libaqhbci20 libavfilter2 libboost-iostreams1.53.0 libboost-serialization1.53.0 libfftw3-3 libllvm3.3:i386 libmjpegutils-2.0-0 libmng1 libmpeg2encpp-2.0-0 libmplex2-2.0-0 libtcl8.5 libtk8.5 libumfpack5.4.0 libwebp4 libx264-123 mono-gmcs python-central python-support slib tcl8.5 tk8.5
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

What can I do to fix this? I'm also worried that I have a potentially unstable system.

Can I run do-release-upgrade again somehow? When I tried it, it, obviously, said I was up to date.

Can I upgrade my installation via the iso? (My installations is fully encrypted (LUKS/LVM), remember that there was a bug/behaviour which didn't support upgrades through iso when encrypted)

I'd really like to avoid doing a fresh installation, I have a backup with deja dup, but re-installing my applications, and setting up system stuff is annoying and really time consuming for me.

share|improve this question
    
thank you @onrea! –  vaioonbuntu Apr 18 at 9:03
    
well i'm using ubuntu gnome, so it was pre-installed. i also added the stable gnome3 ppa, for 3.10 updates: launchpad.net/~gnome3-team/+archive/gnome3 –  vaioonbuntu Apr 18 at 9:16
    
Just remove the PPA! –  Braiam Apr 18 at 23:49

1 Answer 1

gnome-control-center has been replaced by unity-control-center in 14.04. See if you now have unity-control-center installed by typing that in a terminal.

I just run gnome-shell installed in standard (Unity) Ubuntu, and after upgrade 13.10 -> 14.04, the settings icon in gnome-shell 3.10 was still launching the old gnome-control-center binary. I found it in /usr/bin, renamed it to *.bak and created symlink gnome-control-center -> unity-control-center.

That worked fine. Now settings icon in gnome-shell 3.10 launches unity-control-centre. Despite the name, nothing unity-specific about unity-control center, it's just what gnome-control-center is called in 14.04.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.