Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My Dell inspiron 7420 laptop had windows7(home preimium) and ubuntu 13.04 gnome i386 dual boot, and since 4 months i started getting this Read error on boot up or sometimes even

error no such partition, grub rescue

But after trying again and again sometime it started normally

Many times I formatted even windows and ubuntu both after that it works for few days or few hours and again starts giving the same error

On formatting C drive and installing windows7 again today this time I found another error

A disk read error ocurred, Press Ctrl+Alt+Del to restart This never happened earlier.

I thought it would be some problem with GRUB but after seeing this error today I was confused.

I also tried testing hard disk for bad sectors and read errors using Dell diagnostics, chk disk utility, surface tests and hiren's boot disk but found nothing.

what should I do?? Is it a hardware problem??or just some problem with the OS?

share|improve this question
    
Welcome to Ask Ubuntu! What program off of Hirens boot disk did you use to test the disk? Please help us help you! –  Elder Geek May 25 at 16:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.