Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've deleted ~/.macromedia and ~/.adobe contents and after a restart chromium can't detect flash plugin. It works just fine in Firefox

I have only Chromoting Viewer on chrome://plugins/

chromium-browser 34.0.1847.116-0ubuntu2

I have profile-sync-daemon active (tried stopping it, of course) and broken PolicyKit as in NetworkManager broken after upgrade to Kubuntu Saucy

Does the detection depend on PolicyKit? What else can I do?

share|improve this question
the inclusion or exclusion of "adobe" as a tag is being discussed on meta meta.askubuntu.com/questions/9058/… - no further tag edits are warranted until this question has been agreed by the community. Thanks. –  fossfreedom May 7 at 19:16
@fossfreedom actually is here meta.askubuntu.com/questions/9062/… –  Braiam May 8 at 22:56
And that (!) is the argument I agree with, Braiam. –  int_ua May 9 at 15:48
add comment

5 Answers 5

up vote 11 down vote accepted

Chromium 34 in the main repos have started using Aura (early), which does not include support for NPAPI (this is a planned phaseout of NPAPI in Chromium). Therefore, you need to use Pepper Flash to be able to use Flash.

If you have Trusty, you can just run sudo apt-get install pepperflashplugin-nonfree.

If you don't have Trusty, you can use this PPA to install Pepper Flash for any supported Ubuntu version above Precise. Run the following commands to add the PPA and install Pepper Flash:

sudo apt-add-repository ppa:skunk/pepper-flash
sudo apt-get update
sudo apt-get install pepflashplugin-installer

Note that you need to configure Chromium to use Pepper Flash. To do this, open /etc/chromium-browser/default and add the following line to the end of the file on a new line:

. /usr/lib/pepflashplugin-installer/pepflashplayer.sh

Close all windows and re-open.

share|improve this answer
For Ubuntu 14.04 you don't need to add the ppa. Pepper Flash is in Ubuntu repositories. –  Елин Й. Apr 21 at 18:50
On 14.04 I closed all chromium windows, but there were still chromium processes in the background. So if this doesn't work, try rebooting your computer (or go kill processes if you know what you're doing). –  pydave May 6 at 6:43
add comment

I don't know for sure but I found here that Adobe Flash Player support had ended for Chromium from April 2014. I think it is better if you use Firefox Or you could use the Google Chrome rather than Chromium.

share|improve this answer
I know for sure and I can confirm your answer, google posted that on their blog like 6 month ago, people didn't bother reading the articles that google posted on that, and no one spread the news until now –  Fischer Apr 29 at 17:46
they dropped support for second party extensions at first, like Uget downloader, extensions that few use, and say we will drop support for other plugins later like flash, they sent a warning, that's why immediately after reading that article, I dumped chrome and went for firefox, a browser that doesn't downloaders is as useless of a software for me as it can get, I don't need a browser that doesn't support NPAPI –  Fischer Apr 29 at 17:51
Thanks all, helped a lot –  RhZ Apr 29 at 18:38
@Fischer read the button of the blog: "April 2014: NPAPI support was removed from Chrome for Linux in release 35." –  Braiam Apr 29 at 23:52
@Braiam that's what I have been saying above, have I missed something? –  Fischer Apr 29 at 23:57
add comment

Ubuntu 14.04

 sudo apt-get install pepperflashplugin-nonfree

worked for me.

share|improve this answer
Didn't you need to run also the following command: sudo update-pepperflashplugin-nonfree --install? –  Елин Й. Apr 21 at 18:59
No, maybe it was in the postinst script –  int_ua Apr 21 at 20:23
add comment

Chromium dropped support for NPAPI plugins, in favor of their PPAPI. One of them is "Adobe Flash Player" which from April onwards won't work in any version of Chrome/ium. Chrome has the advantage that includes the PepperFlash plugin which is PPAPI so maybe you should use that, or use Firefox in the meanwhile.

share|improve this answer
Last I checked, Chrome still has NPAPI support, since it's not on Aura, but Chromium in Trusty has Aura and so doesn't have NPAPI support. –  saiarcot895 Apr 30 at 0:28
@saiarcot895 chrome 35 beta removed NPAPI support in Linux, I'm bing future proof with this answer. –  Braiam Apr 30 at 0:29
Yes, that is true, but not the stable branch. –  saiarcot895 Apr 30 at 0:36
@saiarcot895 obviously OP isn't in the stable branch ;) –  Braiam Apr 30 at 0:51
add comment

I have in ~/.profile a setting:

export CHROME_USER_FLAGS="--disk-cache-size=50000000 --media-cache-size=25000000"

that messed up the /etc/chromium-browser/default settings removing that line solved the flash player issue

share|improve this answer
add comment

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.