Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I spent hours trying to fix this but nothing worked. I gave it a new shot today but failed. My camera works perfectly fine if I test it in system settings -> Hardware. The problem is skype.

First I installed the libv4l as well as the 32 bit package with

sudo apt-get install ia32-libs

I am running a 64bit version, but I read that skype is programmed for 32 bit so I have to use the i386 library anyway, so I went with

LD_PRELOAD="/usr/lib/i386-linux-gnu/libv4l/v4l2convert.so" skype
LD_PRELOAD="/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so" skype

Both didn't work. I checked the folder. The files are in there.

I also tried different approaches like

LD_PRELOAD="/usr/lib/i386-linux-gnu/libv4l/v4l2convert.so" 
QT_PLUGIN_PATH="/usr/lib/i386-linux-gnu/qt4/plugins" exec /usr/bin/skype --resources=/usr/share/skype --disable-api ...

or

QT_PLUGIN_PATH="/usr/lib/qt4/plugins" exec /usr/bin/skype --resources=/usr/share/skype --disable-api ...

Could it be that my Asus model is not supported yet? I read that I can check it here but to no avail.

Thanks for any help in advance.

share|improve this question
    
I guess I have to wait until I'll buy a new Laptop :S –  user3415062 May 10 at 7:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.