Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ok everyone, I am "sorta" new to ubuntu and am now running a Ubuntu 12.04 LTS server.

I did a basic install of 12.04 lts 64-bit. After initial boot I logged in and ran 'sudo apt-get update'. After this i installed 'ubuntu-desktop' and 64-bit oracle jre. I have configured my static IP using the terminal. Everything was running great until I shutdown this morning to upgrade its RAM. The new ram is installed now and the server is running, but now network manager (ugh) is showing no wired connections. I have scoured the internet for a solution and have yet to find anything wrong with my settings.

I have the server KVM'd to my main desktop pc, and am writing this from that pc. Unfortunately, this makes it hard to copy paste from the server. I will provide any further information needed.

:~$ ifconfig
eth0
      Link encap:Ethernet  HWaddr fc:4d:d4:f5:77:4e  
      inet addr:10.1.10.100  Bcast:10.1.10.255  Mask:255.255.255.0
      inet6 addr: fe80::fe4d:d4ff:fef5:774e/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:380 errors:0 dropped:0 overruns:0 frame:0
      TX packets:120 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:43114 (43.1 KB)  TX bytes:17701 (17.7 KB)
      Interrupt:20 Memory:f7c00000-f7c20000 

lo  Link encap:Local Loopback  
        inet addr:127.0.0.1  Mask:255.0.0.0
        inet6 addr: ::1/128 Scope:Host
        UP LOOPBACK RUNNING  MTU:65536  Metric:1
        RX packets:4640 errors:0 dropped:0 overruns:0 frame:0
        TX packets:4640 errors:0 dropped:0 overruns:0 carrier:0
        collisions:0 txqueuelen:0 
        RX bytes:371208 (371.2 KB) TX bytes:371208 (371.2 KB)

/etc/network/interfaces

#This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
#auto lo
#iface lo inet loopback

# The primary network interface
auto eth0
iface lo inet loopback
iface eth0 inet static
    address 10.1.10.100
    netmask 255.255.255.0
    gateway 10.1.10.1

/etc/resolve.conf is appearently empty now.. must have been reset by network manager...

/etc/NetworkManager/NetworkManger.conf is also empty... i opened this to change it to:

[ifupdown]
manual=true

since I read on ubuntu forums that I needed to do it in order to stop network manager from interfering with my manually configured terminal settings. I am not sure why it is an empty file...

One last thing for now, let me explain what I meant by "Everything was running great". I am running a minecraft server from this machine, it has been running and functioning properly until the shutdown today, and should continue to run after I fix this connection problem. By functioning properly I mean, This morning when i logged in to shut it down, my internet connection was still valid and working and i was still able to connect into the minecraft server from an external IP. I shutdown this morning, removed the RAM and doubled it, upon initial boot I am now stuck with this problem of no internet, yet every command I run appears to show the static is fine and I shouldn't have a problem. Thank you for your help and answers.

share|improve this question
add comment

1 Answer 1

up vote 0 down vote accepted

It's not clear whether you are trying to use the networking service (configured via the /etc/network/interfaces file) or the network-manager service (configured via the GUI). Normally, a true server would use the former, and wouldn't even have a GUI.

You probably need to restore the original lo definition and add some dns-nameservers (I've used Google nameservers 8.8.8.8, 8.8.4.4 here - substitute your own choice(s) as appropriate).

 # This file describes the network interfaces available on your system
 # and how to activate them. For more information, see interfaces(5).
# The loopback network interface auto lo iface lo inet loopback
# The primary network interface auto eth0 iface lo inet loopback address 10.1.10.100 netmask 255.255.255.0 gateway 10.1.10.1 dns-nameservers 8.8.8.8 8.8.4.4

If you're not actually using network-manager then it doesn't really matter what you put in it, however if you want it to show the status of the connection then I believe the appropriate [ifupdown] entry is

[ifupdown]
managed=true

(not manual=true).

share|improve this answer
    
lol yea thats what I meant... "Managed". I apologize, it has been a really long week. Yes I did originally configure it manually using the network service. I have no intention of using the gui's network manager, I installed the gui because its easier for me to be able to view the web through a browser. I only included the network manager part because of what I read here about shutting it down to prevent conflict. sudo-juice.com/how-to-set-a-static-ip-in-ubuntu-the-proper-way I will go make the changes now, Thank you. @steeldriver –  roguemerc Apr 17 at 2:48
    
That fixed it. I was wondering after I discovered the resolve.conf was empty that my only issue might actually be that of the DNS not being there. I had read that it should be put into the /etc/network/interfaces file rather than resolve.conf. Anyways, I have accepted your Answer as the answer to this issue since after reconfiguring it the way you suggested I now have internet connectivity. –  roguemerc Apr 17 at 2:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.