Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Hello and welcome to the toughest question on the internet! Brought to you today by this machine: Toshiba Qosmio x505-q830 core i7 720qm, 4gb DDR3, 320GB HDD, nVidia GTS 250M.

I have tried installing Ubuntu 12.04 desktop 64bit and Linux Mint 16 Petra w/ Cinnamon both produced same results. I am not dual-booting this with anything else, attempting to use a single OS (linux).

In order to run the liveUSB i have to boot with "nomodeset", once booted into the liveUSB install runs perfect and asks for reboot. I reboot, add nomodeset to grub and go from there. Do a update && upgrade. Install "Additional drivers" for nvidia (tried both version 331 and 309), after install i am asked to reboot, i reboot this time without nomodeset and i get a black screen with no activity. Force a shutdown, try to reboot with "nomodeset" and same frozen deal. All of the above repeat with identical results and error messages across ubuntu and linux mint. Below are a few links that may help:

dmesg, syslog, kern, xorg.0 log files -

https://www.dropbox.com/sh/r6hjkuflhwoikae/nqS5ek7qxv

system specs as per Toshiba and verified by me -

http://support.toshiba.com/support/staticContentDetail?contentId=2428599&isFromTOCLink=false

BIOS version currently installed is latest available from Toshiba Support ( v 2.90 )

share|improve this question

1 Answer 1

Do you have optimus enabled in your laptop ? This means that you have both an intel / nvidia graphics chipset, that work together in certain ways to save power. It could be that your linux OS cannot find the nvidia chip , and hence cannot render anything on screen. If this is the case, a straightforward solution might be to try Ubuntu 14.04 , which seems to have the right updates for this to work. I would recommend checking this link out , and installing nvidia-prime/ nvidia drivers (i personally use nvidia-319 drivers).

FYI: i had faced similar issues and solved them only yesterday (used beta2 version of 14.04).

share|improve this answer
    
i only have the dedicated nvidia card in the machine as listed in the specs. i will give trusty a chance though and report back. –  ReddyFire Apr 17 at 1:19
    
Trusty did not have a different impact. same issues as mentioned above...(not sure why i couldn't edit my original comment. –  ReddyFire Apr 17 at 5:04
    
while playing around with various parameters for boot i tried acpi=off and it allowed me to boot successfully into the liveUSB with trusty. I used wiki.ubuntu.com/DebuggingACPI to debug the acpi issue further and found that i cannot boot with acpi=ht. So then what now ? –  ReddyFire Apr 17 at 5:35
    
In this case , i am not sure about what is to be done . My problem was entirely different. I apologize for not being able to help out in this case!. –  Sreekanth Narayanaswamy Apr 24 at 22:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.