Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I use Kubuntu 12.04 64 bit. Currently using the nvidia drivers for my Dell E6510.

When the laptop is docked the two multiple monitors are working perfectly. When I restart when I am undocked the laptop display works fine until I log in to kde. Then the screen goes blank and never returns.

I assume this is an issue with xorg.conf (which I provide below). I have tried using the system without the xorg but it looks terrible and the multiple monitor settings don't work in the default KDE display GUI.

Ideally I would like to be able to undock and dock the machine and for the monitors to behave appropriately. But for now I would be grateful to use my laptop even on a restart when it is undocked.

Below is my xorg.conf:

Section "Monitor"
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "Samsung SyncMaster"
        HorizSync       30.0 - 81.0
        VertRefresh     56.0 - 60.0
        Option         "DPMS"
        # HorizSync source: edid, VertRefresh source: edid
EndSection

Section "Screen"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "Stereo" "0"
        Option         "nvidiaXineramaInfoOrder" "DFP-0"
        Option         "metamodes" "DP-0: nvidia-auto-select +0+0, DP-1: nvidia-auto-select +1920+0"
        Option         "SLI" "Off"
        Option         "MultiGPU" "Off"
        Option         "BaseMosaic" "off"
        SubSection "Display"
                Depth       24
        EndSubSection
EndSection

Section "InputDevice"
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/psaux"
        Option         "Emulate3Buttons" "no"
        Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
        Identifier     "Keyboard0"
        Driver         "kbd"
        # generated from default
EndSection

Section "ServerLayout"
        Identifier     "Layout0"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
        Option         "Xinerama" "0"
EndSection

Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "NVS 3100M"
        Option  "NoLogo"        "True"
EndSection
share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.