Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am building a LTSP environment with LDAP authentication. I have configured the LTSP,LDAP server and client perfectly. I checked with getent passwd command in LTSP/LDAP client. I can see my LDAP users details.

When I booted my LTSP thin client, I am able to login with LDAP user credentials in Alt+Ctrl+F1 mode. But, Not able to login through GUI( lightdm ). See the logs which is from LTSP/LDAP Client.

/var/log/ldm.log:

Apr 15 18:15:53: [ldm] INFO: started on client with IP address: 192.168.12.34
Apr 15 18:15:53: [ldm] INFO: calling rc.d init scripts
Apr 15 18:15:55: [ldm] INFO: authenticating with backend: ssh
Apr 15 18:16:09: [ssh] INFO: calling rc.d pressh scripts
Apr 15 18:16:32: [ssh] CRITICAL: no response, restarting
Apr 15 18:16:34: [ldm] INFO: started on client with IP address: 192.168.12.34
Apr 15 18:16:34: [ldm] INFO: calling rc.d init scripts
Apr 15 18:16:35: [ldm] INFO: authenticating with backend: ssh
Apr 15 18:17:55: [ssh] INFO: calling rc.d pressh scripts
Apr 15 18:18:18: [ssh] CRITICAL: no response, restarting

/var/log/auth.log ( LDAP Server ):

Apr 16 18:41:54 dennis sshd[2727]: Connection closed by 192.168.12.34 [preauth]
Apr 16 18:41:54 dennis sshd[2729]: Connection closed by 192.168.12.34 [preauth]
Apr 16 18:42:09 dennis sshd[2731]: Invalid user myusername from 192.168.12.34
Apr 16 18:42:09 dennis sshd[2731]: input_userauth_request: invalid user myusername [preauth]
Apr 16 18:42:09 dennis sshd[2731]: pam_unix(sshd:auth): check pass; user unknown
Apr 16 18:42:09 dennis sshd[2731]: pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh ruser= rhost=192.168.12.34 
Apr 16 18:42:11 dennis sshd[2731]: Failed password for invalid user myusername from 192.168.12.34 port 38059 ssh2
Apr 16 18:42:11 dennis sshd[2731]: Connection closed by 192.168.12.34 [preauth]

How to solve this?

share|improve this question

1 Answer 1

At the client side run the following:

#authconfig-gtk

Now, try setting the Authentication Configuration as LDAP Password(in the Identity and Authentication tab). It worked for me.

share|improve this answer
    
Are you sure this applies to Ubuntu? authconfig-gtk is not provided by any package. I believe this is for RedHat/CentOS based systems. –  gertvdijk Sep 18 at 11:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.