Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Bumblebee doesn't recognizes my graphic card,

$ lspci | grep -i vga
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation GF108M [GeForce GT 630M] (rev a1)

I have tried installing Bumblebee with the nouveau driver:

sudo apt-get install bumblebee primus

And with the nvidia driver, but i have always the same error:

sudo apt-get install bumblebee-nvidia primus

I have also installed the linux-headers:

sudo apt-get install linux-headers-$(uname -r)

And fore the ACPI mode in the grub, but the error still:

$ optirun blender
[  769.988591] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) No devices detected.
[  769.988627] [ERROR]Aborting because fallback start is disabled.

$ optirun -vv blender
[  806.686792] [DEBUG]Reading file: /etc/bumblebee/bumblebee.conf
[  806.687551] [DEBUG]optirun version 3.2.1 starting...
[  806.687576] [DEBUG]Active configuration:
[  806.687585] [DEBUG] bumblebeed config file: /etc/bumblebee/bumblebee.conf
[  806.687593] [DEBUG] X display: :8
[  806.687600] [DEBUG] LD_LIBRARY_PATH: /usr/lib/nvidia-304:/usr/lib32/nvidia-304
[  806.687608] [DEBUG] Socket path: /var/run/bumblebee.socket
[  806.687616] [DEBUG] Accel/display bridge: auto
[  806.687623] [DEBUG] VGL Compression: proxy
[  806.687631] [DEBUG] VGLrun extra options: 
[  806.687638] [DEBUG] Primus LD Path: /usr/lib/x86_64-linux-gnu/primus:/usr/lib/i386-linux-gnu/primus
[  806.687698] [DEBUG]Using auto-detected bridge virtualgl
[  806.718838] [INFO]Response: No - error: [XORG] (EE) No devices detected.
[  806.718871] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) No devices detected.
[  806.718883] [DEBUG]Socket closed.
[  806.718912] [ERROR]Aborting because fallback start is disabled.
[  806.718922] [DEBUG]Killing all remaining processes.

What can I do?

share|improve this question

1 Answer 1

Install the latest stable NVIDIA drivers supporting GT 630 from the Proprietary GPU drivers PPA.

Before you install new drivers uninstall every NVIDIA related software you have installed before.
This includes removing the bumblebee packages as well - they will be replaced with nvidia-prime.

Open a terminal and execute :

sudo apt-get purge nvidia* bumblebee primus  
sudo reboot

Then install the latest current stable NVIDIA drivers from the long-lived branch by executing :

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update
sudo apt-get install nvidia-352 nvidia-prime
sudo reboot  

To switch between intel and nvidia graphics - open NVIDIA X Server Settings -> Prime Profiles.

Note :

If you are using Ubuntu 15.10 there is no need to add the Proprietary GPU drivers repository (sudo add-apt-repository ppa:graphics-drivers/ppa) - the drivers are already included in the Ubuntu repositories. In case you can adjust it in BIOS select the switchable graphics mode.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.