Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Typing openssl version comes up with the following:

The program 'openssl' is currently not installed.  You can install it by typing:
sudo apt-get install openssl

Typing sudo apt-get install openssl suggests it's already installed:

~$ sudo apt-get install openssl
[sudo] password for systemagic:
Reading package lists... Done
Building dependency tree
Reading state information... Done
openssl is already the newest version..
0 to upgrade, 0 to newly install, 0 to remove and 6 not to upgrade.

Trying to locate it - I can see there is a file in ./usr/bin/openssl

/$ sudo find -name "openssl"
./etc/apparmor.d/abstractions/openssl
./etc/bash_completion.d/openssl
./usr/bin/openssl
./usr/share/doc/openssl

Navigating to this directory it shows openssl as an archive file (red).

Please can you help get the command line working. The server has been patched and rebooted. Running Ubuntu 12.04.4 LTS and the following are present:

ii  libflac8:i386                               1.2.1-6                           Free Lossless Audio Codec - runtime C library
ii  libio-socket-ssl-perl                       1.53-1                            Perl module implementing object oriented interface to SSL sockets
ii  libnet-ssleay-perl                          1.42-1build1                      Perl module for Secure Sockets Layer (SSL)
ii  libssl0.9.8:i386                            0.9.8o-7ubuntu3.1                 SSL shared libraries
ii  libssl1.0.0                                 1.0.1-4ubuntu5.12                 SSL shared libraries
ii  libssl1.0.0:i386                            1.0.1-4ubuntu5.12                 SSL shared libraries
ii  libwavpack1:i386                            4.60.1-2                          audio codec (lossy and lossless) - library
ii  openssl                                     1.0.1-4ubuntu5.12                 Secure Socket Layer (SSL) binary and related cryptographic tools
ii  python-openssl                              0.12-1ubuntu2.1                   Python wrapper around the OpenSSL library
ii  ssl-cert                                    1.0.28ubuntu0.1                   simple debconf wrapper for OpenSSL
share|improve this question
    
From what you show openssl is installed. Have you tried calling /usr/bin/openssl instead of just openssl? Maybe your PATH is not correctly set up. –  Steffen Ullrich Apr 19 at 10:27
    
Yes. Have tried that, thanks. End up with /usr/bin/openssl: No such file or directory. –  snapshot Apr 20 at 13:57
    
Then I would suggest that your system is corrupted, because things which are clearly marked as installed are not there. –  Steffen Ullrich Apr 20 at 15:53

1 Answer 1

If your installation has been corrupted, you may be able to fix OpenSSL by reinstalling openssl and libssl like so:

sudo apt-get --reinstall install openssl libssl1.0.0
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.