Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I upgraded my laptop to the latest release of Ubuntu and now its not loading the normal way from the Grub menu. By normal I mean, picking the "Ubuntu" option from the grub menu.

To load Ubuntu, I have to pick a new option showing up in grub named "Previous Ubuntu version". Why is it acting this way? I have also attached the snapshot where the loading process just gets stuck.

enter image description here

share|improve this question
    
Do you have an external screen plugged in? –  Bryan Agee May 24 '11 at 21:15
    
Bryan I dont. I took this snap shot with my phone. –  t3ch May 25 '11 at 2:30
    
Not an answer, but a tip that will help you solve at least HALF of your diagnostics (and narrow down the solution): Does the same happen if you use an 11.04 Live CD/USB? If not, then theres no incompatibilty between new Ubuntu and your hardware, meaning an upgrade issue. If it also freezes the same way, its probably not an upgrade issue, and solutions must focus on "vanilla" 11.04 incompatibilities with your hardware; –  MestreLion Jun 7 '11 at 11:51

3 Answers 3

Ok, this sort of problem will need some more information, especially the hardware you are using and if you are using any non-standard drivers (either self installed, or via the additional hardware drivers window).

So - if you are happy to try a few things and report back by editing your question, I will likewise (if I have any further ideas), reedit my answer - obviously many of these "try this" stuff will need you to boot into your working kernel or via recovery mode.

1) Possible graphics issue? Maybe you have installed a graphics driver?

Possible solution - remove or rename your xorg.conf file

sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.backup

2) Possible new KMS issue with your graphics card

Try booting with nomodeset as your grub option as described in this AU question and answer

3) Possible new incompatible hardware issue preventing boot

Try removing all plugged in hardware except your monitor, keyboard and mouse. Try to ensure you use a wired keyboard and wired mouse.

4) Possible the upgrade was not completed

Try running

sudo apt-get update && sudo apt-get upgrade

Any errors reported

5) Can you confirm how you upgraded your laptop - did you use update manager from v10.10 to 11.04 or via the live/alternate CD or some other mechanism?

6) Some strange power-management or interrupt issue?

Try booting with either acpi=off or noapic

7) Some sort of strange networking issue?

Try plugging in via a fixed wired connection and hardware disable any wireless card e.g. via BIOS or possibly some switch on the side of your laptop.

Please add to your question details of your hardware i.e.

lsusb
lspci
sudo lshw

N.B. also add to your question that this isnt an external screen issue as per your comment - so that that sort of information doesnt get lost with any other comments. TIA

share|improve this answer
    
Thanks fossfreedom. I will post back with updates following your solution later this evening. Please keep an eye on this question. :) –  t3ch May 31 '11 at 16:38
    
I can answer one of your question right now. "5) Can you confirm how you upgraded your laptop - did you use update manager from v10.10 to 11.04 or via the live/alternate CD or some other mechanism?" - I upgraded using Update Manager from 10.10 to 11.04. –  t3ch May 31 '11 at 16:39

It could be a Problem of a aborted Upgrade. Just pick a previous kernel version, bootup ubuntu and then try to run the update-manager and see if you can finish the upgrade (In case it may be aborted before).

share|improve this answer

Since I don't have the ability to comment yet, I'll just stick this in an answer. I don't think it's an aborted upgrade, since you can boot with an older kernel, however quite a few people have mentioned the possibility of it being a graphics issue, which is a possibility. could you please try to boot, at the grub options screen hit e to edit the current selection, and delete quiet splash with text which will give you a more verbose boot, removing the pretty little splash, and booting you into a text only tty mode. If it is a graphics issue, this should still work, and if the graphics driver freaks out, it should auto switch to vesa. If you want to, after text you can put xforcevesa, which i know works on the livecd, not sure about a reg install, lol.

After that do a reconfigure of your current kernel, and look for dkms to try configuring extra kernel modules:

dpkg --configure -a
dpkg-reconfigure $(uname -r)

If you see something from dkms that says fail, there's the issue. If you have an ATI gfx card or chipset, it's a known issue. The version of fglrx in the repo's isn't patched to support not having the smp.lock file associated with the kernel... which the lovely kernel developers decided didn't have enough of a function to put in 2.6.38 or 2.6.39... Here are links to the patches:

http://www.mindwerks.net/wp-content/uploads/2011/03/2.6.39_bkl.patch http://osdir.com/ml/attachments/txtq2PBdGtr8X.txt

If that is the issue, you can try applying them by patching the fglrx directory in /usr/src then reattempting the second command up there. If it's a nvidia card... I'm at a loss.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.