Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'd like to launch gnome-terminal on my second monitor, you'd expect something like:

~$ gnome-terminal --display=0:0.1

to work but doesn't as RANDR is disabled or not used when xinerama is enabled.

The error I get when trying to launch with this command is:

Failed to parse arguments: Cannot open display: 0:0.1

I've also tried:

~$ export DISPLAY=":0.0"
~$ gnome-terminal --display=$DISPLAY
Xlib:  extension "RANDR" missing on display ":0.0".
** (gnome-terminal:1818): WARNING **: Failed to connect to the session manager: Could not open network socket
share|improve this question
add comment

1 Answer

up vote 3 down vote accepted

There is no syntax to refer to individual monitors in a screen in a display string.

However, you might be able to use the --geometry option to do what you're after. If you have two monitors side by side and the first is 1920 pixels wide, then the following should position a terminal window at (50,50) on the second screen:

gnome-terminal --geometry=80x24+1970+50

The syntax of the argument is ROWSxCOLS+X+Y

share|improve this answer
    
bravo, I ended up with gnome-terminal --geometry=80x24+1440+0 --full-screen –  YHVH May 24 '11 at 23:26
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.