Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using 13.10 on an ASUS n550jv. After resuming from suspend today, the mouse and keyboard stutter and freeze. I move the mouse around and it's extremely choppy. If I'm typing, suddenly characters are no longer being input to the screen. I haven't done anything interesting that could have caused this - I suspended while working and resumed when I got home and everything was terrible.

I should emphasize, that it's not lagging, but dropping the input. If I'm typing and a "stutter" starts, during which I type 10 characters, those 10 characters are lost, they don't appear when the "stutter" stops. So it's not a problem with running too many programs on my CPU, or running out of memory or pulling from disk. It must be a problem with the hardware interface itself. Sometimes the freeze happens after I press a key but before I release it, so the release event is never seen and it behaves as if I'm holding the key down, repeating the character entered.

The stuttering happens when I have no programs running, it happens when I'm on the lightdm login screen. It happens on the virtual terminals (tty1-6).

Any ideas? I'm happy to provide more debugging information, versions, etc. but I don't know what would be useful.

A reboot does not fix the problem. I've tried booting Ubuntu 13.10 with the kernel parameters "pci=noacpi" but the keyboard and mouse are completely unresponsive then. I have to power off the machine with the power button to reboot.

Looking at powertop, I don't have autosuspend enabled for any USB devices, but I don't know if I can trust this. I tried for i in /sys/bus/usb/devices/*/power/autosuspend; do echo -1 > $i; done which caused no change.

Wow, I've never had a bug so suddenly make my computer completely unusable.

Update : I figured out this only happens when on AC power. If I unplug the power cord, the problem disappears. I still have no idea why this happens on AC power.

Update again : This is a manifestation of the bug discussed in this thread. I had plugged my android phone into this usb just to charge its battery, and it triggered the blinking battery light problem. My battery no longer charges on AC power.

I've had this problem before - it seems to be triggered by plugging any externally-powered device into the USB port by the MiniDisplay port on the ASUS N550JV. The hack fix listed in that link is reproduced here, but I'm leaving this open since the problem is not really solved.

1. Remove the T5 Torx screws from the bottom to access the battery.
2. Remove the battery.
3. Plug in the AC power and turn on the laptop.
4. Shutdown the laptop and put the battery pack back in and you are good to go.

Alternative hack fix - Turn off the machine and unplug the AC. Reset the battery by powering off the computer with the power button, but hold down the power button for 5-10 seconds after the computer shuts off. The battery light will be dark the whole time, but after booting again, the problem is resolved. source

share|improve this question

closed as off-topic by bain, chaskes, bodhi.zazen, nux, Eric Carvalho Jul 16 at 11:04

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems specific to development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – bain, chaskes, nux, Eric Carvalho
If this question can be reworded to fit the rules in the help center, please edit the question.

    
Have you tried booting into an USB drive and checking if the problem persists? Also thank you for the thorough description of the problem! It is very helpful for us owners of the same machine. –  genchev Apr 16 at 7:21
    
(+1) Thank you for pointing in the right direction. I faced the very same bug today on my Asus K56C. I removed the battery, turned the laptop on while on AC power, turned off, turned on again with the battery plugged back in - and it worked. –  Quintofron Apr 17 at 12:20
    
Good! You might try the "Alternative fix", since the battery isn't easily accessible (and requires T5 screwdriver). –  reasgt Apr 18 at 18:03
    
The alternative fix worked for me. I hope to discover the reason of this bug, and the irreversible impact it may have –  louiscoquio May 5 at 10:33

Browse other questions tagged or ask your own question.