Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

By default, all hard drive and usb drive devices belong to group "disk". I want to change usb drives to group "adm".

I verified the ID_BUS

$ udevadm info -q all -n /dev/sdb | grep ID_BUS
E: ID_BUS=usb

I created the file /etc/udev/rules.d/70-persistent-usb.rules and insert the following

# Enable admin controls on all usb devices.
ID_BUS=="usb", GROUP="adm"

Lastly, I disconnected my usb drive and reconnected it. It is still showing

$ ll /dev/sdb
brw-rw---- 1 root disk 8, 16 Apr 14 19:31 /dev/sdb

The drive group is not "adm"? What am I doing wrong?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

In the udevadm info output, you see the E prefix which is used for environment variables. You can match against it with:

ENV{ID_BUS}=="..."

If you are trying to make just USB devices writable, see this recent question on Unix.SE:

share|improve this answer

You made a mistake by using ID_BUS to write your udev rule, in that case it's just BUS, try with this one instead:

# Enable admin controls on all usb devices.
BUS=="usb", GROUP="adm"
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.